# CVE-2020-26294: Exposure of server configuration

> An attacker can retrieve sensitive server configuration information via the Sprig env function in the Vela CI/CD compiler.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Jan 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-gv2h-gf8m-r68j, GO-2022-0838

## What is CVE-2020-26294?

CVE-2020-26294 is a high-severity vulnerability in go-vela compiler, published on 4 Jan 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Vela is a Pipeline Automation (CI/CD) framework built on Linux container technology written in Golang. In Vela compiler before version 0.6.1 there is a vulnerability which allows exposure of server configuration. It impacts all users of Vela. An attacker can use Sprig's `env` function to retrieve configuration information, see referenced GHSA for an example. This has been fixed in version 0.6.1. In addition to upgrading, it is recommended to rotate all secrets.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2020-26294?

3 open source packages ship an affected version, including github.com/go-vela/compiler. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/go-vela/compiler` | Go | All versions | 0.6.1 |
| `github.com/go-vela/compiler` | Go | All versions | 0.6.1 |
| `github.com/go-vela/compiler` | Go | All versions | 0.6.1 |

Products: Target Compiler.

## How do I fix CVE-2020-26294?

Upgrade github.com/go-vela/compiler to 0.6.1 or later.

## Is CVE-2020-26294 being exploited?

There is no known exploitation of CVE-2020-26294 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26294 and fix it if it is affected.

What it is: CVE-2020-26294 is a high-severity vulnerability in go-vela compiler, published on 4 Jan 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-26294 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/go-vela/compiler (Go): affected all versions; fixed in 0.6.1
- github.com/go-vela/compiler (Go): affected all versions; fixed in 0.6.1
- github.com/go-vela/compiler (Go): affected all versions; fixed in 0.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26294/ (Markdown: https://insights.sbomify.com/CVE-2020-26294/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26294
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26294
- OSV: https://osv.dev/vulnerability/CVE-2020-26294

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26294/
Summaries are generated and may contain mistakes; the official description above is the record.
