{"answers":{"affected":"2 open source packages ship an affected version, including vega. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-26296 in the wild and no public exploit code.","fix":"Upgrade vega to 5.17.3 or later.","what":"CVE-2020-26296 is a high-severity cross-site scripting vulnerability in vega, published on 30 Dec 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-26296 and fix it if it is affected.\n\nWhat it is: CVE-2020-26296 is a high-severity cross-site scripting vulnerability in vega, published on 30 Dec 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-26296 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vega (npm): affected all versions; fixed in 5.17.3\n- vega (npm): affected all versions; fixed in 5.17.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-26296/ (Markdown: https://insights.sbomify.com/CVE-2020-26296/index.md)","id":"CVE-2020-26296","markdown":"https://insights.sbomify.com/CVE-2020-26296/index.md","name":"CVE-2020-26296","record":{"aliases":["GHSA-r2qc-w64x-6j54"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Vega visualization library","requires_auth":"low_privilege","summary":"An attacker can execute arbitrary JavaScript on a victim's machine via crafted Vega expressions in the visualization library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vega","vendor":"vega_project"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. Vega in an npm package. In Vega before version 5.17.3 there is an XSS vulnerability in Vega expressions. Through a specially crafted Vega expression, an attacker could execute arbitrary javascript on a victim's machine. This is fixed in version 5.17.3","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XSS in Vega","id":"CVE-2020-26296","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":5,"next":{"headline":"XSS in mdBook's search page","id":"CVE-2020-26297"},"packages":[{"ecosystem":"npm","fixed":["5.17.3"],"introduced":["0"],"last_affected":[],"package":"vega","purl":null,"source":"GHSA-r2qc-w64x-6j54"},{"ecosystem":"npm","fixed":["5.17.3"],"introduced":["0"],"last_affected":[],"package":"vega","purl":"pkg:npm/vega","source":"GHSA-r2qc-w64x-6j54"}],"prev":{"headline":"CMS Editor code execution","id":"CVE-2020-26295"},"products":["vega"],"published":"2020-12-30","related":[{"cvss_score":8.1,"headline":"Vega XSS via expression abusing vlSelectionTuples function array map calls in environments with satisfactory function gadgets in the global scope","id":"CVE-2025-65110","kev_date_added":null,"published":"2026-01-05"},{"cvss_score":4.3,"headline":"Improperly Controlled Modification of Dynamically-Determined Object Attributes in vega-util","id":"CVE-2019-10806","kev_date_added":null,"published":"2020-03-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["vega"]},"summary":"An attacker can execute arbitrary JavaScript on a victim's machine via crafted Vega expressions in the visualization library.","url":"https://insights.sbomify.com/CVE-2020-26296/"}