{"answers":{"affected":"2 open source packages ship an affected version, including ssh2. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-26301 in the wild and no public exploit code.","fix":"Upgrade ssh2 to 1.4.0 or later.","what":"CVE-2020-26301 is a high-severity vulnerability in mscdex ssh2, published on 20 Sep 2021."},"fix_prompt":"Check this codebase for CVE-2020-26301 and fix it if it is affected.\n\nWhat it is: CVE-2020-26301 is a high-severity vulnerability in mscdex ssh2, published on 20 Sep 2021. \nExploitation: There is no known exploitation of CVE-2020-26301 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ssh2 (npm): affected all versions; fixed in 1.4.0\n- ssh2 (npm): affected all versions; fixed in 1.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-26301/ (Markdown: https://insights.sbomify.com/CVE-2020-26301/index.md)","id":"CVE-2020-26301","markdown":"https://insights.sbomify.com/CVE-2020-26301/index.md","name":"CVE-2020-26301","record":{"aliases":["GHSA-652h-xwhf-q4h6"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"ssh2","vendor":"ssh2_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"ssh2 is client and server modules written in pure JavaScript for node.js. In ssh2 before version 1.4.0 there is a command injection vulnerability. The issue only exists on Windows. This issue may lead to remote code execution if a client of the library calls the vulnerable method with untrusted input. This is fixed in version 1.4.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command injection in mscdex/ssh2","id":"CVE-2020-26301","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":null,"year":"2020"},"n_packages":2,"n_references":3,"next":{"headline":"is_js vulnerable to Regular Expression Denial of Service","id":"CVE-2020-26302"},"packages":[{"ecosystem":"npm","fixed":["1.4.0"],"introduced":["0"],"last_affected":[],"package":"ssh2","purl":null,"source":"GHSA-652h-xwhf-q4h6"},{"ecosystem":"npm","fixed":["1.4.0"],"introduced":["0"],"last_affected":[],"package":"ssh2","purl":"pkg:npm/ssh2","source":"GHSA-652h-xwhf-q4h6"}],"prev":{"headline":"Command injection in systeminformation","id":"CVE-2020-26300"},"products":["ssh2"],"published":"2021-09-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["mscdex"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2020-26301/"}