# CVE-2020-26301: Command injection in mscdex/ssh2


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Sep 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-652h-xwhf-q4h6

## What is CVE-2020-26301?

CVE-2020-26301 is a high-severity vulnerability in mscdex ssh2, published on 20 Sep 2021. 

### Official description

ssh2 is client and server modules written in pure JavaScript for node.js. In ssh2 before version 1.4.0 there is a command injection vulnerability. The issue only exists on Windows. This issue may lead to remote code execution if a client of the library calls the vulnerable method with untrusted input. This is fixed in version 1.4.0.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2020-26301?

2 open source packages ship an affected version, including ssh2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ssh2` | npm | All versions | 1.4.0 |
| `ssh2` | npm | All versions | 1.4.0 |

Products: Ssh2 Project Ssh2.

## How do I fix CVE-2020-26301?

Upgrade ssh2 to 1.4.0 or later.

## Is CVE-2020-26301 being exploited?

There is no known exploitation of CVE-2020-26301 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26301 and fix it if it is affected.

What it is: CVE-2020-26301 is a high-severity vulnerability in mscdex ssh2, published on 20 Sep 2021. 
Exploitation: There is no known exploitation of CVE-2020-26301 in the wild and no public exploit code.

Affected packages and fixed versions:
- ssh2 (npm): affected all versions; fixed in 1.4.0
- ssh2 (npm): affected all versions; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26301/ (Markdown: https://insights.sbomify.com/CVE-2020-26301/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26301
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26301
- OSV: https://osv.dev/vulnerability/CVE-2020-26301

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26301/
Summaries are generated and may contain mistakes; the official description above is the record.
