{"answers":{"affected":"2 open source packages ship an affected version, including nope-validator.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-26309 exists.","fix":"Upgrade nope-validator to 0.12.1 or later.","what":"CVE-2020-26309 is a high-severity denial of service vulnerability in ftonato nope-validator, published on 26 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-26309 and fix it if it is affected.\n\nWhat it is: CVE-2020-26309 is a high-severity denial of service vulnerability in ftonato nope-validator, published on 26 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-26309 exists.\n\nAffected packages and fixed versions:\n- nope-validator (npm): affected all versions; fixed in 0.12.1\n- nope-validator (npm): affected all versions; fixed in 0.12.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-26309/ (Markdown: https://insights.sbomify.com/CVE-2020-26309/index.md)","id":"CVE-2020-26309","markdown":"https://insights.sbomify.com/CVE-2020-26309/index.md","name":"CVE-2020-26309","record":{"aliases":["GHSA-3phv-83cj-p8p7"],"analysis":{"component_type":"library","fix_type":"no_fix_stated","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript validation library","requires_auth":"none","summary":"Attackers can cause denial of service in applications using nope-validator by submitting inputs that trigger inefficient regular expression processing.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/U:Green","version":"4.0"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"Validate.js provides a declarative way of validating javascript objects. Versions 0.11.3 and prior contain one or more regular expressions that are vulnerable to Regular Expression Denial of Service (ReDoS). As of time of publication, it is unknown if any patches are available.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"GHSL-2020-303: Regular Expression Denial of Service (ReDoS) in nope-validator","id":"CVE-2020-26309","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"GHSL-2020-305: Regular Expression Denial of Service (ReDoS) in Pure JavaScript HTML5 Parser","id":"CVE-2020-26310"},"packages":[{"ecosystem":"npm","fixed":["0.12.1"],"introduced":["0"],"last_affected":[],"package":"nope-validator","purl":null,"source":"GHSA-3phv-83cj-p8p7"},{"ecosystem":"npm","fixed":["0.12.1"],"introduced":["0"],"last_affected":[],"package":"nope-validator","purl":"pkg:npm/nope-validator","source":"GHSA-3phv-83cj-p8p7"}],"prev":{"headline":"GHSL-2020-302: Regular Expression Denial of Service (ReDoS) in validate.js","id":"CVE-2020-26308"},"products":["nope-validator"],"published":"2024-10-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-28","vendors":["ftonato"]},"summary":"Attackers can cause denial of service in applications using nope-validator by submitting inputs that trigger inefficient regular expression processing.","url":"https://insights.sbomify.com/CVE-2020-26309/"}