# CVE-2020-26309: GHSL-2020-303: Regular Expression Denial of Service (ReDoS) in nope-validator

> Attackers can cause denial of service in applications using nope-validator by submitting inputs that trigger inefficient regular expression processing.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/U:Green`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Oct 2024
- **Updated:** 28 Oct 2024
- **Also known as:** GHSA-3phv-83cj-p8p7

## What is CVE-2020-26309?

CVE-2020-26309 is a high-severity denial of service vulnerability in ftonato nope-validator, published on 26 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Validate.js provides a declarative way of validating javascript objects. Versions 0.11.3 and prior contain one or more regular expressions that are vulnerable to Regular Expression Denial of Service (ReDoS). As of time of publication, it is unknown if any patches are available.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2020-26309?

2 open source packages ship an affected version, including nope-validator.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nope-validator` | npm | All versions | 0.12.1 |
| `nope-validator` | npm | All versions | 0.12.1 |

## How do I fix CVE-2020-26309?

Upgrade nope-validator to 0.12.1 or later.

## Is CVE-2020-26309 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-26309 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26309 and fix it if it is affected.

What it is: CVE-2020-26309 is a high-severity denial of service vulnerability in ftonato nope-validator, published on 26 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-26309 exists.

Affected packages and fixed versions:
- nope-validator (npm): affected all versions; fixed in 0.12.1
- nope-validator (npm): affected all versions; fixed in 0.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26309/ (Markdown: https://insights.sbomify.com/CVE-2020-26309/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26309
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26309
- OSV: https://osv.dev/vulnerability/CVE-2020-26309

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26309/
Summaries are generated and may contain mistakes; the official description above is the record.
