CVE-2020-26409 Denial of service in GitLab CE/EE
An attacker can cause a denial of service in GitLab by bypassing input validation in markdown fields to trigger uncontrolled resource consumption.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-26409?
CVE-2020-26409 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 11 Dec 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A DOS vulnerability exists in Gitlab CE/EE >=10.3, <13.4.7,>=13.5, <13.5.5,>=13.6, <13.6.2 that allows an attacker to trigger uncontrolled resource by bypassing input validation in markdown fields.
Which versions are affected by CVE-2020-26409?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | All versions | 13.6.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2020-26409?
Upgrade gitlab to 13.6.2 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2020-26409 being exploited?
There is no known exploitation of CVE-2020-26409 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2020-26409, GHSA-3jr7-57xj-6hhm, UBUNTU-CVE-2020-26409.