CVE-2020-26411 Denial of service in GitLab

Medium 4.3 Published Updated

Attackers can cause denial of service in GitLab by using specific project search queries that trigger statement timeouts.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-26411?

CVE-2020-26411 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 11 Dec 2020. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A potential DOS vulnerability was discovered in all versions of Gitlab starting from 13.4.x (>=13.4 to <13.4.7, >=13.5 to <13.5.5, and >=13.6 to <13.6.2). Using a specific query name for a project search can cause statement timeouts that can lead to a potential DOS if abused.

Weakness: CWE-404

Which versions are affected by CVE-2020-26411?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 13.4.013.4.7, 13.5.5, 13.6.2

Products include Gitlab Gitlab.

How do I fix CVE-2020-26411?

Upgrade gitlab to a fixed version for your release line: 13.4.7, 13.5.5 or 13.6.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2020-26411 being exploited?

There is no known exploitation of CVE-2020-26411 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2020-26411, GHSA-2qvv-wf53-7c44, UBUNTU-CVE-2020-26411.

Is CVE-2020-26411 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free