CVE-2020-2654 Denial of service in Java
An unauthenticated attacker can cause a partial denial of service in Java SE by supplying data to specific library APIs.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-2654?
CVE-2020-2654 is a low-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 15 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Vulnerability in the Java SE product of Oracle Java SE (component: Libraries). Supported versions that are affected are Java SE: 7u241, 8u231, 11.0.5 and 13.0.1. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE. Successful attacks of this vulnerability can result in unauthorized ability to cause a partial denial of service (partial DOS) of Java SE. Note: This vulnerability can only be exploited by supplying data to APIs in the specified Component without using Untrusted Java Web Start applications or Untrusted Java applets, such as through a web service. CVSS 3.0 Base Score 3.7 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L).
Which versions are affected by CVE-2020-2654?
3 open source packages ship an affected version, including java, java-min and jre. It affects 23 products.
| Package | Affected | Fixed in |
|---|---|---|
java Bitnami | All versions | 1.7.0, 1.8.0, 7.0.251, 8.0.241, 11.0.6, 13.0.2 |
java-min Bitnami | All versions | 1.7.0, 1.8.0, 7.0.251, 8.0.241, 11.0.6, 13.0.2 |
jre Bitnami | All versions | 1.7.0, 1.8.0, 7.0.251, 8.0.241, 11.0.6, 13.0.2 |
Products include Canonical Ubuntu Linux, Debian Debian Linux, Mcafee Epolicy Orchestrator, Netapp Active Iq Unified Manager, Netapp E-Series Performance Analyzer, Netapp E-Series Santricity Management Plug-Ins and 17 more.
How do I fix CVE-2020-2654?
Upgrade java to a fixed version for your release line: 1.7.0, 1.8.0, 7.0.251 or 8.0.241.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2020-2654 being exploited?
There is no known exploitation of CVE-2020-2654 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as BIT-java-2020-2654, BIT-java-min-2020-2654, BIT-jre-2020-2654, CLEANSTART-2026-RB34373, CLEANSTART-2026-WX84482, DEBIAN-CVE-2020-2654 and 7 more.