# CVE-2020-2654: Denial of service in Java

> An unauthenticated attacker can cause a partial denial of service in Java SE by supplying data to specific library APIs.

- **Severity:** Low 3.7 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jan 2020
- **Updated:** 30 Sep 2024
- **Also known as:** BIT-java-2020-2654, BIT-java-min-2020-2654, BIT-jre-2020-2654, CLEANSTART-2026-RB34373, CLEANSTART-2026-WX84482, DEBIAN-CVE-2020-2654, GHSA-wx3r-hh3w-28wg, MINI-32g2-4w55-4m2c, MINI-833w-6m38-3h5q, MINI-cmr6-qrp7-25cf, MINI-jr49-pmr5-xm3g, MINI-xc88-mhmf-xwh8, UBUNTU-CVE-2020-2654

## What is CVE-2020-2654?

CVE-2020-2654 is a low-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 15 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vulnerability in the Java SE product of Oracle Java SE (component: Libraries). Supported versions that are affected are Java SE: 7u241, 8u231, 11.0.5 and 13.0.1. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE. Successful attacks of this vulnerability can result in unauthorized ability to cause a partial denial of service (partial DOS) of Java SE. Note: This vulnerability can only be exploited by supplying data to APIs in the specified Component without using Untrusted Java Web Start applications or Untrusted Java applets, such as through a web service. CVSS 3.0 Base Score 3.7 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L).

## Which versions are affected by CVE-2020-2654?

3 open source packages ship an affected version, including java, java-min and jre. It affects 23 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `java` | Bitnami | All versions | 1.7.0, 1.8.0, 7.0.251, 8.0.241, 11.0.6, 13.0.2 |
| `java-min` | Bitnami | All versions | 1.7.0, 1.8.0, 7.0.251, 8.0.241, 11.0.6, 13.0.2 |
| `jre` | Bitnami | All versions | 1.7.0, 1.8.0, 7.0.251, 8.0.241, 11.0.6, 13.0.2 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Mcafee Epolicy Orchestrator, Netapp Active Iq Unified Manager, Netapp E-Series Performance Analyzer, Netapp E-Series Santricity Management Plug-Ins, Netapp E-Series Santricity Os Controller, Netapp E-Series Santricity Storage Manager, Netapp E-Series Santricity Web Services Proxy, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation, Netapp Santricity Unified Manager, Netapp Steelstore Cloud Integrated Storage, Opensuse Leap, Oracle Jdk, Oracle Jre, Oracle Openjdk, Redhat Enterprise Linux, Redhat Enterprise Linux Desktop, Redhat Enterprise Linux Eus and 3 more.

## How do I fix CVE-2020-2654?

Upgrade java to a fixed version for your release line: 1.7.0, 1.8.0, 7.0.251 or 8.0.241.

## Is CVE-2020-2654 being exploited?

There is no known exploitation of CVE-2020-2654 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2654 and fix it if it is affected.

What it is: CVE-2020-2654 is a low-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 15 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-2654 in the wild and no public exploit code.

Affected packages and fixed versions:
- java (Bitnami): affected all versions; fixed in 1.7.0, 1.8.0, 7.0.251, 8.0.241, 11.0.6, 13.0.2
- java-min (Bitnami): affected all versions; fixed in 1.7.0, 1.8.0, 7.0.251, 8.0.241, 11.0.6, 13.0.2
- jre (Bitnami): affected all versions; fixed in 1.7.0, 1.8.0, 7.0.251, 8.0.241, 11.0.6, 13.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2654/ (Markdown: https://insights.sbomify.com/CVE-2020-2654/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2654
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2654
- OSV: https://osv.dev/vulnerability/CVE-2020-2654

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2654/
Summaries are generated and may contain mistakes; the official description above is the record.
