CVE-2020-26882 Data Amplification in Play Framework
Attackers can cause denial of service via data amplification in Play Framework applications accepting multipart/form-data JSON input.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-26882?
CVE-2020-26882 is a high-severity denial of service vulnerability in n/a, published on 6 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Play Framework 2.6.0 through 2.8.2, data amplification can occur when an application accepts multipart/form-data JSON input.
Weakness: CWE-674
Which versions are affected by CVE-2020-26882?
4 open source packages ship an affected version, including com.typesafe.play:play. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
com.typesafe.play:play Maven | From 2.6.0 | 2.7.6 |
com.typesafe.play:play Maven | From 2.6.0 | 2.7.6 |
com.typesafe.play:play Maven | From 2.8.0 | 2.8.3 |
com.typesafe.play:play Maven | From 2.8.0 | 2.8.3 |
Products include Lightbend Play Framework.
How do I fix CVE-2020-26882?
Upgrade com.typesafe.play:play to a fixed version for your release line: 2.7.6 or 2.8.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2020-26882 being exploited?
There is no known exploitation of CVE-2020-26882 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-r8rm-4hfj-2x87.