# CVE-2020-26883: Uncontrolled Recursion in Play Framework

> Attackers can cause denial of service in Play Framework applications by sending crafted JSON documents that trigger unbounded recursion and stack exhaustion.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-p8p6-rcp6-4mrm

## What is CVE-2020-26883?

CVE-2020-26883 is a high-severity denial of service vulnerability in n/a, published on 6 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Play Framework 2.6.0 through 2.8.2, stack consumption can occur because of unbounded recursion during parsing of crafted JSON documents.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2020-26883?

8 open source packages ship an affected version, including com.typesafe.play:play and com.typesafe.play:play-java. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.typesafe.play:play` | Maven | From 2.6.0 | 2.7.6 |
| `com.typesafe.play:play` | Maven | From 2.6.0 | 2.7.6 |
| `com.typesafe.play:play` | Maven | From 2.8.0 | 2.8.3 |
| `com.typesafe.play:play` | Maven | From 2.8.0 | 2.8.3 |
| `com.typesafe.play:play-java` | Maven | From 2.6.0 | 2.7.6 |
| `com.typesafe.play:play-java` | Maven | From 2.6.0 | 2.7.6 |
| `com.typesafe.play:play-java` | Maven | From 2.8.0 | 2.8.3 |
| `com.typesafe.play:play-java` | Maven | From 2.8.0 | 2.8.3 |

Products: Lightbend Play Framework.

## How do I fix CVE-2020-26883?

Upgrade com.typesafe.play:play to a fixed version for your release line: 2.7.6 or 2.8.3.

## Is CVE-2020-26883 being exploited?

There is no known exploitation of CVE-2020-26883 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-3630](https://insights.sbomify.com/CVE-2014-3630/): XML external entity in n/a (critical 9.8)
- [CVE-2022-31018](https://insights.sbomify.com/CVE-2022-31018/): Denial of service binding form from JSON in Play Framework (high 7.5)
- [CVE-2020-26882](https://insights.sbomify.com/CVE-2020-26882/): Data Amplification in Play Framework (high 7.5)
- [CVE-2020-27196](https://insights.sbomify.com/CVE-2020-27196/): Out-of-bounds Write in Play Framework (high 7.5)
- [CVE-2019-17598](https://insights.sbomify.com/CVE-2019-17598/): Play Framework Inadequate Encryption Strength vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26883 and fix it if it is affected.

What it is: CVE-2020-26883 is a high-severity denial of service vulnerability in n/a, published on 6 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-26883 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.typesafe.play:play (Maven): affected from 2.6.0; fixed in 2.7.6
- com.typesafe.play:play (Maven): affected from 2.6.0; fixed in 2.7.6
- com.typesafe.play:play (Maven): affected from 2.8.0; fixed in 2.8.3
- com.typesafe.play:play (Maven): affected from 2.8.0; fixed in 2.8.3
- com.typesafe.play:play-java (Maven): affected from 2.6.0; fixed in 2.7.6
- com.typesafe.play:play-java (Maven): affected from 2.6.0; fixed in 2.7.6
- com.typesafe.play:play-java (Maven): affected from 2.8.0; fixed in 2.8.3
- com.typesafe.play:play-java (Maven): affected from 2.8.0; fixed in 2.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26883/ (Markdown: https://insights.sbomify.com/CVE-2020-26883/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26883
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26883
- OSV: https://osv.dev/vulnerability/CVE-2020-26883

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26883/
Summaries are generated and may contain mistakes; the official description above is the record.
