# CVE-2020-26890: Denial of service attack due to invalid JSON

> Remote attackers can cause persistent denial of service in Matrix Synapse by sending malformed JSON values in room member events.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-4mp3-385r-v63f, PYSEC-2020-237, UBUNTU-CVE-2020-26890

## What is CVE-2020-26890?

CVE-2020-26890 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 24 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Matrix Synapse before 1.20.0 erroneously permits non-standard NaN, Infinity, and -Infinity JSON values in fields of m.room.member events, allowing remote attackers to execute a denial of service attack against the federation and common Matrix clients. If such a malformed event is accepted into the room's state, the impact is long-lasting and is not fixed by an upgrade to a newer version, requiring the event to be manually redacted instead. Since events are replicated to servers of other room members, the impact is not constrained to the server of the event sender.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-26890?

3 open source packages ship an affected version, including matrix-synapse. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 1.20.0 |
| `matrix-synapse` | PyPI | All versions | 1.20.0 |
| `matrix-synapse` | PyPI | All versions | 1.20.0 |

Products: Fedoraproject Fedora, Matrix Synapse.

## How do I fix CVE-2020-26890?

Upgrade matrix-synapse to 1.20.0 or later.

## Is CVE-2020-26890 being exploited?

There is no known exploitation of CVE-2020-26890 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26890 and fix it if it is affected.

What it is: CVE-2020-26890 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 24 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-26890 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 1.20.0
- matrix-synapse (PyPI): affected all versions; fixed in 1.20.0
- matrix-synapse (PyPI): affected all versions; fixed in 1.20.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26890/ (Markdown: https://insights.sbomify.com/CVE-2020-26890/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26890
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26890
- OSV: https://osv.dev/vulnerability/CVE-2020-26890

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26890/
Summaries are generated and may contain mistakes; the official description above is the record.
