CVE-2020-26934 phpMyAdmin Cross-site Scripting (XSS)
Attackers can execute arbitrary scripts in victim browsers via crafted links in phpMyAdmin's transformation feature, potentially leading to session hijacking.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-26934?
CVE-2020-26934 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 10 Oct 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
phpMyAdmin before 4.9.6 and 5.x before 5.0.3 allows XSS through the transformation feature via a crafted link.
Weakness: CWE-79
Which versions are affected by CVE-2020-26934?
5 open source packages ship an affected version, including phpmyadmin/phpmyadmin and phpmyadmin. It affects 5 products.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.9.0 | 4.9.6 |
phpmyadmin/phpmyadmin Packagist | From 4.9.0 | 4.9.6 |
phpmyadmin/phpmyadmin Packagist | From 5.0.0 | 5.0.3 |
phpmyadmin/phpmyadmin Packagist | From 5.0.0 | 5.0.3 |
phpmyadmin Bitnami | From 4.9.0 | 4.9.6, 5.0.3 |
Products include Debian Debian Linux, Fedoraproject Fedora, Opensuse Backports Sle, Opensuse Leap, Phpmyadmin Phpmyadmin.
How do I fix CVE-2020-26934?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.9.6 or 5.0.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-26934 being exploited?
There is no known exploitation of CVE-2020-26934 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-phpmyadmin-2020-26934, DEBIAN-CVE-2020-26934, GHSA-6349-53vr-7hcr, UBUNTU-CVE-2020-26934.