CVE-2020-26935 phpMyAdmin SQL injection vulnerability
An attacker can inject malicious SQL into queries via the search feature in phpMyAdmin, potentially reading or modifying database contents.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-26935?
CVE-2020-26935 is a critical SQL injection vulnerability in Debian Debian Linux, published on 10 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in SearchController in phpMyAdmin before 4.9.6 and 5.x before 5.0.3. A SQL injection vulnerability was discovered in how phpMyAdmin processes SQL statements in the search feature. An attacker could use this flaw to inject malicious SQL in to a query.
Weakness: CWE-89
Which versions are affected by CVE-2020-26935?
5 open source packages ship an affected version, including phpmyadmin/phpmyadmin and phpmyadmin. It affects 5 products.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.9.0 | 4.9.6 |
phpmyadmin/phpmyadmin Packagist | From 4.9.0 | 4.9.6 |
phpmyadmin/phpmyadmin Packagist | From 5.0.0 | 5.0.3 |
phpmyadmin/phpmyadmin Packagist | From 5.0.0 | 5.0.3 |
phpmyadmin Bitnami | From 4.9.0 | 4.9.6, 5.0.3 |
Products include Debian Debian Linux, Fedoraproject Fedora, Opensuse Backports Sle, Opensuse Leap, Phpmyadmin Phpmyadmin.
How do I fix CVE-2020-26935?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.9.6 or 5.0.3.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2020-26935 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-26935 exists.
Public exploit code: 1 Nuclei template.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-phpmyadmin-2020-26935, DEBIAN-CVE-2020-26935, GHSA-7ff4-cv53-4cjq, UBUNTU-CVE-2020-26935.