{"answers":{"affected":"5 open source packages ship an affected version, including phpmyadmin/phpmyadmin and phpmyadmin. It affects 5 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-26935 exists.","fix":"Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.9.6 or 5.0.3.","what":"CVE-2020-26935 is a critical SQL injection vulnerability in Debian Debian Linux, published on 10 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-26935 and fix it if it is affected.\n\nWhat it is: CVE-2020-26935 is a critical SQL injection vulnerability in Debian Debian Linux, published on 10 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-26935 exists.\n\nAffected packages and fixed versions:\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.9.0; fixed in 4.9.6\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.9.0; fixed in 4.9.6\n- phpmyadmin/phpmyadmin (Packagist): affected from 5.0.0; fixed in 5.0.3\n- phpmyadmin/phpmyadmin (Packagist): affected from 5.0.0; fixed in 5.0.3\n- phpmyadmin (Bitnami): affected from 4.9.0; fixed in 4.9.6, 5.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-26935/ (Markdown: https://insights.sbomify.com/CVE-2020-26935/index.md)","id":"CVE-2020-26935","markdown":"https://insights.sbomify.com/CVE-2020-26935/index.md","name":"CVE-2020-26935","record":{"aliases":["BIT-phpmyadmin-2020-26935","DEBIAN-CVE-2020-26935","GHSA-7ff4-cv53-4cjq","UBUNTU-CVE-2020-26935"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"phpMyAdmin","requires_auth":"none","summary":"An attacker can inject malicious SQL into queries via the search feature in phpMyAdmin, potentially reading or modifying database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"backports_sle","vendor":"opensuse"},{"product":"leap","vendor":"opensuse"},{"product":"phpmyadmin","vendor":"phpmyadmin"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"An issue was discovered in SearchController in phpMyAdmin before 4.9.6 and 5.x before 5.0.3. A SQL injection vulnerability was discovered in how phpMyAdmin processes SQL statements in the search feature. An attacker could use this flaw to inject malicious SQL in to a query.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2020/CVE-2020-26935.yaml","stars":null,"title":"phpMyAdmin \u003c 5.0.3 - SQL Injection"}],"tier":"weaponised"},"has_fix":true,"headline":"phpMyAdmin SQL injection vulnerability","id":"CVE-2020-26935","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora","opensuse:backports_sle","opensuse:leap","phpmyadmin:phpmyadmin"],"type":"sql_injection","year":"2020"},"n_packages":5,"n_references":9,"next":{"headline":"Cross-site request forgery in n/a","id":"CVE-2020-26936"},"packages":[{"ecosystem":"Bitnami","fixed":["4.9.6","5.0.3"],"introduced":["4.9.0","5.0.0"],"last_affected":[],"package":"phpmyadmin","purl":"pkg:bitnami/phpmyadmin","source":"BIT-phpmyadmin-2020-26935"},{"ecosystem":"Packagist","fixed":["4.9.6"],"introduced":["4.9.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-7ff4-cv53-4cjq"},{"ecosystem":"Packagist","fixed":["4.9.6"],"introduced":["4.9.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-7ff4-cv53-4cjq"},{"ecosystem":"Packagist","fixed":["5.0.3"],"introduced":["5.0.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-7ff4-cv53-4cjq"},{"ecosystem":"Packagist","fixed":["5.0.3"],"introduced":["5.0.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-7ff4-cv53-4cjq"}],"prev":{"headline":"phpMyAdmin Cross-site Scripting (XSS)","id":"CVE-2020-26934"},"products":["n/a"],"published":"2020-10-10","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"An attacker can inject malicious SQL into queries via the search feature in phpMyAdmin, potentially reading or modifying database contents.","url":"https://insights.sbomify.com/CVE-2020-26935/"}