# CVE-2020-26935: phpMyAdmin SQL injection vulnerability

> An attacker can inject malicious SQL into queries via the search feature in phpMyAdmin, potentially reading or modifying database contents.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-phpmyadmin-2020-26935, DEBIAN-CVE-2020-26935, GHSA-7ff4-cv53-4cjq, UBUNTU-CVE-2020-26935

## What is CVE-2020-26935?

CVE-2020-26935 is a critical SQL injection vulnerability in Debian Debian Linux, published on 10 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in SearchController in phpMyAdmin before 4.9.6 and 5.x before 5.0.3. A SQL injection vulnerability was discovered in how phpMyAdmin processes SQL statements in the search feature. An attacker could use this flaw to inject malicious SQL in to a query.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2020-26935?

5 open source packages ship an affected version, including phpmyadmin/phpmyadmin and phpmyadmin. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.9.0 | 4.9.6 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.9.0 | 4.9.6 |
| `phpmyadmin/phpmyadmin` | Packagist | From 5.0.0 | 5.0.3 |
| `phpmyadmin/phpmyadmin` | Packagist | From 5.0.0 | 5.0.3 |
| `phpmyadmin` | Bitnami | From 4.9.0 | 4.9.6, 5.0.3 |

Products: Debian Debian Linux, Fedoraproject Fedora, Opensuse Backports Sle, Opensuse Leap, Phpmyadmin Phpmyadmin.

## How do I fix CVE-2020-26935?

Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.9.6 or 5.0.3.

## Is CVE-2020-26935 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-26935 exists.

Public exploit code:

- phpMyAdmin < 5.0.3 - SQL Injection (nuclei): http/cves/2020/CVE-2020-26935.yaml

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26935 and fix it if it is affected.

What it is: CVE-2020-26935 is a critical SQL injection vulnerability in Debian Debian Linux, published on 10 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-26935 exists.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 4.9.0; fixed in 4.9.6
- phpmyadmin/phpmyadmin (Packagist): affected from 4.9.0; fixed in 4.9.6
- phpmyadmin/phpmyadmin (Packagist): affected from 5.0.0; fixed in 5.0.3
- phpmyadmin/phpmyadmin (Packagist): affected from 5.0.0; fixed in 5.0.3
- phpmyadmin (Bitnami): affected from 4.9.0; fixed in 4.9.6, 5.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26935/ (Markdown: https://insights.sbomify.com/CVE-2020-26935/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26935
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26935
- OSV: https://osv.dev/vulnerability/CVE-2020-26935

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26935/
Summaries are generated and may contain mistakes; the official description above is the record.
