CVE-2020-27178 Improper Authentication in Apereo CAS
Attackers can bypass multifactor authentication in Apereo CAS due to mishandled secret keys with Google Authenticator.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-27178?
CVE-2020-27178 is a high-severity authentication bypass vulnerability in n/a, published on 16 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apereo CAS 5.3.x before 5.3.16, 6.x before 6.1.7.2, 6.2.x before 6.2.4, and 6.3.x before 6.3.0-RC4 mishandles secret keys with Google Authenticator for multifactor authentication.
Which versions are affected by CVE-2020-27178?
12 open source packages ship an affected version, including org.apereo.cas:cas-server-support-otp-mfa-core and org.apereo.cas:cas-server-webapp. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apereo.cas:cas-server-support-otp-mfa-core Maven | From 5.3.0 | 5.3.16 |
org.apereo.cas:cas-server-support-otp-mfa-core Maven | From 5.3.0 | 5.3.16 |
org.apereo.cas:cas-server-support-otp-mfa-core Maven | From 6.0.0 | 6.1.7.2 |
org.apereo.cas:cas-server-support-otp-mfa-core Maven | From 6.0.0 | 6.1.7.2 |
org.apereo.cas:cas-server-support-otp-mfa-core Maven | From 6.2.0 | 6.2.4 |
org.apereo.cas:cas-server-support-otp-mfa-core Maven | From 6.2.0 | 6.2.4 |
6 more packages
org.apereo.cas:cas-server-webapp Maven | From 5.3.0 | 5.3.16 |
org.apereo.cas:cas-server-webapp Maven | From 5.3.0 | 5.3.16 |
org.apereo.cas:cas-server-webapp Maven | From 6.0.0 | 6.1.7.2 |
org.apereo.cas:cas-server-webapp Maven | From 6.0.0 | 6.1.7.2 |
org.apereo.cas:cas-server-webapp Maven | From 6.2.0 | 6.2.4 |
org.apereo.cas:cas-server-webapp Maven | From 6.2.0 | 6.2.4 |
Products include Apereo Central Authentication Service.
How do I fix CVE-2020-27178?
Upgrade org.apereo.cas:cas-server-support-otp-mfa-core to a fixed version for your release line: 5.3.16, 6.1.7.2 or 6.2.4.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2020-27178 being exploited?
There is no known exploitation of CVE-2020-27178 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-q39c-5vh5-vw2p.