# CVE-2020-27178: Improper Authentication in Apereo CAS

> Attackers can bypass multifactor authentication in Apereo CAS due to mishandled secret keys with Google Authenticator.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-q39c-5vh5-vw2p

## What is CVE-2020-27178?

CVE-2020-27178 is a high-severity authentication bypass vulnerability in n/a, published on 16 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apereo CAS 5.3.x before 5.3.16, 6.x before 6.1.7.2, 6.2.x before 6.2.4, and 6.3.x before 6.3.0-RC4 mishandles secret keys with Google Authenticator for multifactor authentication.

## Which versions are affected by CVE-2020-27178?

12 open source packages ship an affected version, including org.apereo.cas:cas-server-support-otp-mfa-core and org.apereo.cas:cas-server-webapp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apereo.cas:cas-server-support-otp-mfa-core` | Maven | From 5.3.0 | 5.3.16 |
| `org.apereo.cas:cas-server-support-otp-mfa-core` | Maven | From 5.3.0 | 5.3.16 |
| `org.apereo.cas:cas-server-support-otp-mfa-core` | Maven | From 6.0.0 | 6.1.7.2 |
| `org.apereo.cas:cas-server-support-otp-mfa-core` | Maven | From 6.0.0 | 6.1.7.2 |
| `org.apereo.cas:cas-server-support-otp-mfa-core` | Maven | From 6.2.0 | 6.2.4 |
| `org.apereo.cas:cas-server-support-otp-mfa-core` | Maven | From 6.2.0 | 6.2.4 |
| `org.apereo.cas:cas-server-webapp` | Maven | From 5.3.0 | 5.3.16 |
| `org.apereo.cas:cas-server-webapp` | Maven | From 5.3.0 | 5.3.16 |
| `org.apereo.cas:cas-server-webapp` | Maven | From 6.0.0 | 6.1.7.2 |
| `org.apereo.cas:cas-server-webapp` | Maven | From 6.0.0 | 6.1.7.2 |
| `org.apereo.cas:cas-server-webapp` | Maven | From 6.2.0 | 6.2.4 |
| `org.apereo.cas:cas-server-webapp` | Maven | From 6.2.0 | 6.2.4 |

Products: Apereo Central Authentication Service.

## How do I fix CVE-2020-27178?

Upgrade org.apereo.cas:cas-server-support-otp-mfa-core to a fixed version for your release line: 5.3.16, 6.1.7.2 or 6.2.4.

## Is CVE-2020-27178 being exploited?

There is no known exploitation of CVE-2020-27178 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-4612](https://insights.sbomify.com/CVE-2023-4612/): MFA bypass in Apereo CAS (critical 9.8)
- [CVE-2024-4399](https://insights.sbomify.com/CVE-2024-4399/): CAS <= 1.0.0 - Unauthenticated SSRF (critical 9.1)
- [CVE-2019-10754](https://insights.sbomify.com/CVE-2019-10754/): Use of Insufficiently Random Values in Apereo CAS (high 8.1)
- [CVE-2015-1169](https://insights.sbomify.com/CVE-2015-1169/): Auth bypass in n/a (high 7.5)
- [CVE-2024-11208](https://insights.sbomify.com/CVE-2024-11208/): Apereo CAS login session expiration (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-27178 and fix it if it is affected.

What it is: CVE-2020-27178 is a high-severity authentication bypass vulnerability in n/a, published on 16 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-27178 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apereo.cas:cas-server-support-otp-mfa-core (Maven): affected from 5.3.0; fixed in 5.3.16
- org.apereo.cas:cas-server-support-otp-mfa-core (Maven): affected from 5.3.0; fixed in 5.3.16
- org.apereo.cas:cas-server-support-otp-mfa-core (Maven): affected from 6.0.0; fixed in 6.1.7.2
- org.apereo.cas:cas-server-support-otp-mfa-core (Maven): affected from 6.0.0; fixed in 6.1.7.2
- org.apereo.cas:cas-server-support-otp-mfa-core (Maven): affected from 6.2.0; fixed in 6.2.4
- org.apereo.cas:cas-server-support-otp-mfa-core (Maven): affected from 6.2.0; fixed in 6.2.4
- org.apereo.cas:cas-server-webapp (Maven): affected from 5.3.0; fixed in 5.3.16
- org.apereo.cas:cas-server-webapp (Maven): affected from 5.3.0; fixed in 5.3.16
- org.apereo.cas:cas-server-webapp (Maven): affected from 6.0.0; fixed in 6.1.7.2
- org.apereo.cas:cas-server-webapp (Maven): affected from 6.0.0; fixed in 6.1.7.2
- org.apereo.cas:cas-server-webapp (Maven): affected from 6.2.0; fixed in 6.2.4
- org.apereo.cas:cas-server-webapp (Maven): affected from 6.2.0; fixed in 6.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-27178/ (Markdown: https://insights.sbomify.com/CVE-2020-27178/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-27178
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-27178
- OSV: https://osv.dev/vulnerability/CVE-2020-27178

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-27178/
Summaries are generated and may contain mistakes; the official description above is the record.
