# CVE-2020-27197: libtaxii Server-Side Request Forgery vulnerability

> An attacker can trigger Server-Side Request Forgery in the libtaxii library by manipulating URL parsing, bypassing network restrictions.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-836c-xg97-8p4h, PYSEC-2020-59

## What is CVE-2020-27197?

CVE-2020-27197 is a critical server-side request forgery vulnerability in n/a, published on 17 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

TAXII libtaxii through 1.1.117, as used in EclecticIQ OpenTAXII through 0.2.0 and other products, allows SSRF via an initial http:// substring to the parse method, even when the no_network setting is used for the XML parser. NOTE: the vendor points out that the parse method "wraps the lxml library" and that this may be an issue to "raise ... to the lxml group.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2020-27197?

3 open source packages ship an affected version, including libtaxii. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libtaxii` | PyPI | All versions | 1.1.118 |
| `libtaxii` | PyPI | All versions | 1.1.118 |
| `libtaxii` | PyPI | All versions | 1.1.118 |

Products: Eclecticiq Opentaxii, Libtaxii Project Libtaxii.

## How do I fix CVE-2020-27197?

Upgrade libtaxii to 1.1.118 or later.

## Is CVE-2020-27197 being exploited?

There is no known exploitation of CVE-2020-27197 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-27197 and fix it if it is affected.

What it is: CVE-2020-27197 is a critical server-side request forgery vulnerability in n/a, published on 17 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-27197 in the wild and no public exploit code.

Affected packages and fixed versions:
- libtaxii (PyPI): affected all versions; fixed in 1.1.118
- libtaxii (PyPI): affected all versions; fixed in 1.1.118
- libtaxii (PyPI): affected all versions; fixed in 1.1.118

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-27197/ (Markdown: https://insights.sbomify.com/CVE-2020-27197/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-27197
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-27197
- OSV: https://osv.dev/vulnerability/CVE-2020-27197

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-27197/
Summaries are generated and may contain mistakes; the official description above is the record.
