# CVE-2020-27218: Buffer not correctly recycled in Gzip Request inflation

> Attackers can inject data into subsequent request bodies when GZIP inflation is enabled and requests are multiplexed, potentially corrupting application data.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-kafka-2020-27218, BIT-spark-2020-27218, DEBIAN-CVE-2020-27218, GHSA-86wm-rrjm-8wh8, SUSE-SU-2020:3922-1, UBUNTU-CVE-2020-27218, openSUSE-SU-2021:0012-1

## What is CVE-2020-27218?

CVE-2020-27218 is a medium-severity vulnerability in Debian Debian Linux, published on 28 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Eclipse Jetty version 9.4.0.RC0 to 9.4.34.v20201102, 10.0.0.alpha0 to 10.0.0.beta2, and 11.0.0.alpha0 to 11.0.0.beta2, if GZIP request body inflation is enabled and requests from different clients are multiplexed onto a single connection, and if an attacker can send a request with a body that is received entirely but not consumed by the application, then a subsequent request on the same connection will see that body prepended to its body. The attacker will not see any data but may inject data into the body of the subsequent request.

Weakness: CWE-226 (Sensitive Information in Resource Not Removed Before Reuse)

## Which versions are affected by CVE-2020-27218?

4 open source packages ship an affected version, including org.eclipse.jetty:jetty-server, kafka and spark. It affects 17 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.4.0 | 9.4.35.v20201120 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.4.0 | 9.4.35.v20201120 |
| `kafka` | Bitnami | From 2.7.0 | 2.7.1 |
| `spark` | Bitnami | From 2.4.8 | 2.4.9, 3.0.4 |
| `jetty-minimal` | SUSE:Linux Enterprise Module for Development Tools 15 SP2 | All versions | 9.4.35-3.3.4 |
| `jetty-minimal` | openSUSE:Leap 15.2 | All versions | 9.4.35-lp152.2.3.1 |
| `jetty-websocket` | openSUSE:Leap 15.2 | All versions | 9.4.35-lp152.2.3.1 |

Products: Apache Kafka, Apache Spark, Debian Debian Linux, Eclipse Jetty, Netapp Oncommand System Manager, Netapp Snap Creator Framework, Oracle Blockchain Platform, Oracle Communications Converged Application Server - Service Controller, Oracle Communications Offline Mediation Controller, Oracle Communications Pricing Design Center, Oracle Communications Services Gatekeeper, Oracle Communications Session Route Manager, Oracle Flexcube Private Banking, Oracle Hyperion Infrastructure Technology, Oracle Rest Data Services, Oracle Retail Eftlink, Oracle Siebel Core - Automation.

## How do I fix CVE-2020-27218?

Upgrade org.eclipse.jetty:jetty-server to 9.4.35.v20201120 or later.

## Is CVE-2020-27218 being exploited?

There is no known exploitation of CVE-2020-27218 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2026-33557](https://insights.sbomify.com/CVE-2026-33557/): Apache Kafka: Missing JWT token validation in OAUTHBEARER authentication (critical 9.1)
- [CVE-2025-27818](https://insights.sbomify.com/CVE-2025-27818/): Apache Kafka: Possible RCE attack via SASL JAAS LdapLoginModule configuration (high 8.8)
- [CVE-2018-17196](https://insights.sbomify.com/CVE-2018-17196/): Improper Input Validation in Apache Kafka (high 8.8)
- [CVE-2026-35554](https://insights.sbomify.com/CVE-2026-35554/): Apache Kafka Clients: Kafka Producer Message Corruption and Misrouting via Buffer Pool Race Condition (high 8.7)
- [CVE-2025-27817](https://insights.sbomify.com/CVE-2025-27817/): Apache Kafka Client: Arbitrary file read and SSRF vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-27218 and fix it if it is affected.

What it is: CVE-2020-27218 is a medium-severity vulnerability in Debian Debian Linux, published on 28 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-27218 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.eclipse.jetty:jetty-server (Maven): affected from 9.4.0; fixed in 9.4.35.v20201120
- org.eclipse.jetty:jetty-server (Maven): affected from 9.4.0; fixed in 9.4.35.v20201120
- kafka (Bitnami): affected from 2.7.0; fixed in 2.7.1
- spark (Bitnami): affected from 2.4.8; fixed in 2.4.9, 3.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-27218/ (Markdown: https://insights.sbomify.com/CVE-2020-27218/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-27218
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-27218
- OSV: https://osv.dev/vulnerability/CVE-2020-27218

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-27218/
Summaries are generated and may contain mistakes; the official description above is the record.
