# CVE-2020-27223: DOS vulnerability for Quoted Quality CSV headers

> Attackers can cause high CPU usage and denial of service in Eclipse Jetty by sending requests with numerous quality parameters in Accept headers.

- **Severity:** Medium 5.2 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Feb 2021
- **Updated:** 20 Aug 2025
- **Also known as:** BIT-nifi-2020-27223, BIT-solr-2020-27223, BIT-spark-2020-27223, DEBIAN-CVE-2020-27223, GHSA-m394-8rww-3jr7, SUSE-SU-2021:0940-1, UBUNTU-CVE-2020-27223

## What is CVE-2020-27223?

CVE-2020-27223 is a medium-severity denial of service vulnerability in Apache Nifi, published on 26 Feb 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

In Eclipse Jetty 9.4.6.v20170531 to 9.4.36.v20210114 (inclusive), 10.0.0, and 11.0.0 when Jetty handles a request containing multiple Accept headers with a large number of “quality” (i.e. q) parameters, the server may enter a denial of service (DoS) state due to high CPU usage processing those quality values, resulting in minutes of CPU time exhausted processing those quality values.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2020-27223?

9 open source packages ship an affected version, including nifi, solr and spark. It affects 16 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nifi` | Bitnami | From 1.13.0 to 1.13.0 | None |
| `solr` | Bitnami | From 8.8.1 | 8.8.2 |
| `spark` | Bitnami | From 3.1.1 | 3.1.2 |
| `org.eclipse.jetty:jetty-server` | Maven | From 10.0.0 | 10.0.1 |
| `org.eclipse.jetty:jetty-server` | Maven | From 10.0.0 | 10.0.1 |
| `org.eclipse.jetty:jetty-server` | Maven | From 11.0.0 | 11.0.1 |
| `org.eclipse.jetty:jetty-server` | Maven | From 11.0.0 | 11.0.1 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.4.6 | 9.4.37 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.4.6 | 9.4.37 |
| `jetty-minimal` | SUSE:Linux Enterprise Module for Development Tools 15 SP2 | All versions | 9.4.38-3.6.2 |

Products: Apache Nifi, Apache Solr, Apache Spark, Debian Debian Linux, Eclipse Jetty, Netapp E-Series Santricity Os Controller, Netapp E-Series Santricity Web Services, Netapp Element Plug-in for Vcenter Server, Netapp Hci, Netapp Hci Management Node, Netapp Management Services for Element Software, Netapp Snap Creator Framework, Netapp Snapcenter, Netapp Snapmanager, Netapp Solidfire, Oracle Rest Data Services.

## How do I fix CVE-2020-27223?

Upgrade to a fixed version.

## Is CVE-2020-27223 being exploited?

There is no known exploitation of CVE-2020-27223 in the wild and no public exploit code.

Public exploit code:

- CVE-2020-27223 Vulnerability App & PoC (github_poc): https://github.com/motikan2010/CVE-2020-27223
- https://github.com/ttestoo/Jetty-CVE-2020-27223 (github_poc): https://github.com/ttestoo/Jetty-CVE-2020-27223

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-27223 and fix it if it is affected.

What it is: CVE-2020-27223 is a medium-severity denial of service vulnerability in Apache Nifi, published on 26 Feb 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-27223 in the wild and no public exploit code.

Affected packages and fixed versions:
- nifi (Bitnami): affected from 1.13.0 up to 1.13.0; no fix listed
- solr (Bitnami): affected from 8.8.1; fixed in 8.8.2
- spark (Bitnami): affected from 3.1.1; fixed in 3.1.2
- org.eclipse.jetty:jetty-server (Maven): affected from 10.0.0; fixed in 10.0.1
- org.eclipse.jetty:jetty-server (Maven): affected from 10.0.0; fixed in 10.0.1
- org.eclipse.jetty:jetty-server (Maven): affected from 11.0.0; fixed in 11.0.1
- org.eclipse.jetty:jetty-server (Maven): affected from 11.0.0; fixed in 11.0.1
- org.eclipse.jetty:jetty-server (Maven): affected from 9.4.6; fixed in 9.4.37
- org.eclipse.jetty:jetty-server (Maven): affected from 9.4.6; fixed in 9.4.37

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-27223/ (Markdown: https://insights.sbomify.com/CVE-2020-27223/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-27223
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-27223
- OSV: https://osv.dev/vulnerability/CVE-2020-27223

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-27223/
Summaries are generated and may contain mistakes; the official description above is the record.
