{"answers":{"affected":"3 open source packages ship an affected version, including snapcraft. It affects 2 products.","exploited":"There is no known exploitation of CVE-2020-27348 in the wild and no public exploit code.","fix":"Upgrade snapcraft to a fixed version for your release line: 2.43.1 or 4.4.4.","what":"CVE-2020-27348 is a medium-severity path traversal vulnerability in Canonical Ubuntu Linux, published on 4 Dec 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-27348 and fix it if it is affected.\n\nWhat it is: CVE-2020-27348 is a medium-severity path traversal vulnerability in Canonical Ubuntu Linux, published on 4 Dec 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-27348 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- snapcraft (PyPI): affected all versions; fixed in 2.43.1\n- snapcraft (PyPI): affected all versions; fixed in 4.4.4\n- snapcraft (PyPI): affected all versions; fixed in 4.4.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-27348/ (Markdown: https://insights.sbomify.com/CVE-2020-27348/index.md)","id":"CVE-2020-27348","markdown":"https://insights.sbomify.com/CVE-2020-27348/index.md","name":"CVE-2020-27348","record":{"aliases":["GHSA-qxm5-vx5j-pp6w","PYSEC-2020-109","UBUNTU-CVE-2020-27348","USN-4661-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Snapcraft build tool","requires_auth":"low_privilege","summary":"Snapcraft may build snaps with unsafe LD_LIBRARY_PATH, allowing malicious snaps to execute code in other snaps sharing interfaces.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"canonical","cpe":[{"product":"snapcraft","vendor":"canonical"},{"product":"ubuntu_linux","vendor":"canonical"}],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-427","name":"Uncontrolled Search Path Element"}],"description":"In some conditions, a snap package built by snapcraft includes the current directory in LD_LIBRARY_PATH, allowing a malicious snap to gain code execution within the context of another snap if both plug the home interface or similar. This issue affects snapcraft versions prior to 4.4.4, prior to 2.43.1+16.04.1, and prior to 2.43.1+18.04.1.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"snapcraft may build snaps with incorrect LD_LIBRARY_PATH","id":"CVE-2020-27348","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux"],"type":"path_traversal","year":"2020"},"n_packages":3,"n_references":3,"next":{"headline":"aptdaemon performed policykit permissions checks too late","id":"CVE-2020-27349"},"packages":[{"ecosystem":"PyPI","fixed":["2.43.1"],"introduced":["0"],"last_affected":[],"package":"snapcraft","purl":"pkg:pypi/snapcraft","source":"PYSEC-2020-109"},{"ecosystem":"PyPI","fixed":["4.4.4"],"introduced":["0"],"last_affected":[],"package":"snapcraft","purl":null,"source":"GHSA-qxm5-vx5j-pp6w"},{"ecosystem":"PyPI","fixed":["4.4.4"],"introduced":["0"],"last_affected":[],"package":"snapcraft","purl":"pkg:pypi/snapcraft","source":"GHSA-qxm5-vx5j-pp6w"}],"prev":{"headline":"tmux stack buffer overflow in function input_csi_dispatch_sgr_colon","id":"CVE-2020-27347"},"products":["snapcraft"],"published":"2020-12-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Canonical"]},"summary":"Snapcraft may build snaps with unsafe LD_LIBRARY_PATH, allowing malicious snaps to execute code in other snaps sharing interfaces.","url":"https://insights.sbomify.com/CVE-2020-27348/"}