{"answers":{"affected":"2 open source packages ship an affected version, including yourls/yourls. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-27388 in the wild and no public exploit code.","fix":"Upgrade yourls/yourls to 1.8 or later.","what":"CVE-2020-27388 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Oct 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-27388 and fix it if it is affected.\n\nWhat it is: CVE-2020-27388 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Oct 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-27388 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- yourls/yourls (Packagist): affected from 1.5; fixed in 1.8\n- yourls/yourls (Packagist): affected from 1.5; fixed in 1.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-27388/ (Markdown: https://insights.sbomify.com/CVE-2020-27388/index.md)","id":"CVE-2020-27388","markdown":"https://insights.sbomify.com/CVE-2020-27388/index.md","name":"CVE-2020-27388","record":{"aliases":["GHSA-pwgg-r6fq-mf94"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"YOURLS URL shortener","requires_auth":"low_privilege","summary":"Authenticated users can inject malicious scripts via PHP plugins in YOURLS, leading to stored XSS attacks against other users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"yourls","vendor":"yourls"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Multiple Stored Cross Site Scripting (XSS) vulnerabilities exist in the YOURLS Admin Panel, Versions 1.5 - 1.7.10. An authenticated user must modify a PHP plugin with a malicious payload and upload it, resulting in multiple stored XSS issues.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"YOURLS Stored Cross Site Scripting (XSS)","id":"CVE-2020-27388","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"File upload in n/a","id":"CVE-2020-27397"},"packages":[{"ecosystem":"Packagist","fixed":["1.8"],"introduced":["1.5"],"last_affected":[],"package":"yourls/yourls","purl":null,"source":"GHSA-pwgg-r6fq-mf94"},{"ecosystem":"Packagist","fixed":["1.8"],"introduced":["1.5"],"last_affected":[],"package":"yourls/yourls","purl":"pkg:composer/yourls/yourls","source":"GHSA-pwgg-r6fq-mf94"}],"prev":{"headline":"File upload in n/a","id":"CVE-2020-27387"},"products":["n/a"],"published":"2020-10-23","related":[{"cvss_score":9.8,"headline":"Access of Resource Using Incompatible Type ('Type Confusion') in yourls/yourls","id":"CVE-2019-14537","kev_date_added":null,"published":"2019-08-07"},{"cvss_score":8.8,"headline":"Cross-site Scripting (XSS) - Stored in yourls/yourls","id":"CVE-2021-3785","kev_date_added":null,"published":"2021-09-15"},{"cvss_score":6.6,"headline":"Cross-site Scripting (XSS) - Reflected in yourls/yourls","id":"CVE-2021-3783","kev_date_added":null,"published":"2021-09-15"},{"cvss_score":6.5,"headline":"Improper Restriction of Rendered UI Layers or Frames in yourls/yourls","id":"CVE-2021-3734","kev_date_added":null,"published":"2021-08-26"},{"cvss_score":5,"headline":"Information disclosure in n/a","id":"CVE-2011-3824","kev_date_added":null,"published":"2011-09-24"},{"cvss_score":3.5,"headline":"Cross-Site Request Forgery (CSRF) in yourls/yourls","id":"CVE-2022-0088","kev_date_added":null,"published":"2022-04-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2026-07-09","vendors":["n/a"]},"summary":"Authenticated users can inject malicious scripts via PHP plugins in YOURLS, leading to stored XSS attacks against other users.","url":"https://insights.sbomify.com/CVE-2020-27388/"}