# CVE-2020-27388: YOURLS Stored Cross Site Scripting (XSS)

> Authenticated users can inject malicious scripts via PHP plugins in YOURLS, leading to stored XSS attacks against other users.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Oct 2020
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-pwgg-r6fq-mf94

## What is CVE-2020-27388?

CVE-2020-27388 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Oct 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Multiple Stored Cross Site Scripting (XSS) vulnerabilities exist in the YOURLS Admin Panel, Versions 1.5 - 1.7.10. An authenticated user must modify a PHP plugin with a malicious payload and upload it, resulting in multiple stored XSS issues.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-27388?

2 open source packages ship an affected version, including yourls/yourls. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yourls/yourls` | Packagist | From 1.5 | 1.8 |
| `yourls/yourls` | Packagist | From 1.5 | 1.8 |

Products: Yourls Yourls.

## How do I fix CVE-2020-27388?

Upgrade yourls/yourls to 1.8 or later.

## Is CVE-2020-27388 being exploited?

There is no known exploitation of CVE-2020-27388 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-14537](https://insights.sbomify.com/CVE-2019-14537/): Access of Resource Using Incompatible Type ('Type Confusion') in yourls/yourls (critical 9.8)
- [CVE-2021-3785](https://insights.sbomify.com/CVE-2021-3785/): Cross-site Scripting (XSS) - Stored in yourls/yourls (high 8.8)
- [CVE-2021-3783](https://insights.sbomify.com/CVE-2021-3783/): Cross-site Scripting (XSS) - Reflected in yourls/yourls (medium 6.6)
- [CVE-2021-3734](https://insights.sbomify.com/CVE-2021-3734/): Improper Restriction of Rendered UI Layers or Frames in yourls/yourls (medium 6.5)
- [CVE-2011-3824](https://insights.sbomify.com/CVE-2011-3824/): Information disclosure in n/a (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-27388 and fix it if it is affected.

What it is: CVE-2020-27388 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Oct 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-27388 in the wild and no public exploit code.

Affected packages and fixed versions:
- yourls/yourls (Packagist): affected from 1.5; fixed in 1.8
- yourls/yourls (Packagist): affected from 1.5; fixed in 1.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-27388/ (Markdown: https://insights.sbomify.com/CVE-2020-27388/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-27388
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-27388
- OSV: https://osv.dev/vulnerability/CVE-2020-27388

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-27388/
Summaries are generated and may contain mistakes; the official description above is the record.
