{"answers":{"affected":"3 open source packages ship an affected version, including blackduck. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-27589 in the wild and no public exploit code.","fix":"Upgrade blackduck to 0.0.53 or later.","what":"CVE-2020-27589 is a high-severity vulnerability in n/a, published on 6 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-27589 and fix it if it is affected.\n\nWhat it is: CVE-2020-27589 is a high-severity vulnerability in n/a, published on 6 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-27589 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- blackduck (PyPI): affected from 0.0.25; fixed in 0.0.53\n- blackduck (PyPI): affected from 0.0.25; fixed in 0.0.53\n- blackduck (PyPI): affected from 0.0.25; fixed in 0.0.53\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-27589/ (Markdown: https://insights.sbomify.com/CVE-2020-27589/index.md)","id":"CVE-2020-27589","markdown":"https://insights.sbomify.com/CVE-2020-27589/index.md","name":"CVE-2020-27589","record":{"aliases":["GHSA-f248-v4qh-x2r6","PYSEC-2020-26"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python API client","requires_auth":"none","summary":"The Synopsys hub-rest-api-python library fails to validate SSL certificates, allowing attackers to bypass security checks and potentially intercept traffic.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"hub-rest-api-python","vendor":"synopsys"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"Synopsys hub-rest-api-python (aka blackduck on PyPI) version 0.0.25 - 0.0.52 does not validate SSL certificates in certain cases.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Certificate Validation in blackduck","id":"CVE-2020-27589","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"weak_cryptography","year":"2020"},"n_packages":3,"n_references":5,"next":{"headline":"Command injection in n/a","id":"CVE-2020-27600"},"packages":[{"ecosystem":"PyPI","fixed":["0.0.53"],"introduced":["0.0.25"],"last_affected":[],"package":"blackduck","purl":null,"source":"GHSA-f248-v4qh-x2r6"},{"ecosystem":"PyPI","fixed":["0.0.53"],"introduced":["0.0.25"],"last_affected":[],"package":"blackduck","purl":"pkg:pypi/blackduck","source":"GHSA-f248-v4qh-x2r6"},{"ecosystem":"PyPI","fixed":["0.0.53"],"introduced":["0.0.25"],"last_affected":[],"package":"blackduck","purl":"pkg:pypi/blackduck","source":"PYSEC-2020-26"}],"prev":{"headline":"Weak cryptography in n/a","id":"CVE-2020-27587"},"products":["n/a"],"published":"2020-11-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"The Synopsys hub-rest-api-python library fails to validate SSL certificates, allowing attackers to bypass security checks and potentially intercept traffic.","url":"https://insights.sbomify.com/CVE-2020-27589/"}