# CVE-2020-27619: Code injection in n/a

> Attackers can execute arbitrary code by exploiting eval() on HTTP-retrieved content in Python's CJK codec tests.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Oct 2020
- **Updated:** 8 Oct 2026
- **Also known as:** BIT-libpython-2020-27619, BIT-python-2020-27619, BIT-python-min-2020-27619, CLSA-2024-1721401321, CLSA-2024-1721401573, DEBIAN-CVE-2020-27619, GHSA-22cq-cq7f-8jm3, MGASA-2020-0477, MGASA-2021-0327, PSF-2020-6, SUSE-SU-2021:1621-1, UBUNTU-CVE-2020-27619

## What is CVE-2020-27619?

CVE-2020-27619 is a critical code injection vulnerability in Fedoraproject Fedora, published on 22 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Python 3 through 3.9.0, the Lib/test/multibytecodec_support.py CJK codec tests call eval() on content retrieved via HTTP.

## Which versions are affected by CVE-2020-27619?

3 open source packages ship an affected version, including libpython, python and python-min. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libpython` | Bitnami | From 3.0.0 | 3.6.13, 3.7.10, 3.8.7, 3.9.1 |
| `python` | Bitnami | From 3.0.0 | 3.6.13, 3.7.10, 3.8.7, 3.9.1 |
| `python-min` | Bitnami | From 3.0.0 | 3.6.13, 3.7.10, 3.8.7, 3.9.1 |
| `python3` | SUSE:HPE Helion OpenStack 8 | All versions | 3.4.10-25.71.1 |
| `python3-base` | SUSE:HPE Helion OpenStack 8 | All versions | 3.4.10-25.71.1 |
| `python3` | SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 3.4.10-25.71.1 |
| `python3-base` | SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 3.4.10-25.71.1 |
| `python3` | SUSE:Linux Enterprise Server 12 SP2-BCL | All versions | 3.4.10-25.71.1 |
| `python3-base` | SUSE:Linux Enterprise Server 12 SP2-BCL | All versions | 3.4.10-25.71.1 |
| `python3` | SUSE:Linux Enterprise Server 12 SP3-BCL | All versions | 3.4.10-25.71.1 |
| `python3-base` | SUSE:Linux Enterprise Server 12 SP3-BCL | All versions | 3.4.10-25.71.1 |
| `python3` | SUSE:Linux Enterprise Server 12 SP3-LTSS | All versions | 3.4.10-25.71.1 |
| `python3-base` | SUSE:Linux Enterprise Server 12 SP3-LTSS | All versions | 3.4.10-25.71.1 |
| `python3` | SUSE:Linux Enterprise Server 12 SP4-LTSS | All versions | 3.4.10-25.71.1 |
| `python3-base` | SUSE:Linux Enterprise Server 12 SP4-LTSS | All versions | 3.4.10-25.71.1 |
| `python3` | SUSE:Linux Enterprise Server 12 SP5 | All versions | 3.4.10-25.71.1 |
| `python3-base` | SUSE:Linux Enterprise Server 12 SP5 | All versions | 3.4.10-25.71.1 |
| `python3` | SUSE:Linux Enterprise Server for SAP Applications 12 SP3 | All versions | 3.4.10-25.71.1 |
| `python3-base` | SUSE:Linux Enterprise Server for SAP Applications 12 SP3 | All versions | 3.4.10-25.71.1 |
| `python3` | SUSE:Linux Enterprise Server for SAP Applications 12 SP4 | All versions | 3.4.10-25.71.1 |
| `python3-base` | SUSE:Linux Enterprise Server for SAP Applications 12 SP4 | All versions | 3.4.10-25.71.1 |
| `python3` | SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 3.4.10-25.71.1 |
| `python3-base` | SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 3.4.10-25.71.1 |
| `python3` | SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 3.4.10-25.71.1 |
| `python3-base` | SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 3.4.10-25.71.1 |
| `python3` | SUSE:OpenStack Cloud 8 | All versions | 3.4.10-25.71.1 |
| `python3-base` | SUSE:OpenStack Cloud 8 | All versions | 3.4.10-25.71.1 |
| `python3` | SUSE:OpenStack Cloud 9 | All versions | 3.4.10-25.71.1 |
| `python3-base` | SUSE:OpenStack Cloud 9 | All versions | 3.4.10-25.71.1 |
| `python3` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 3.4.10-25.71.1 |
| `python3-base` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 3.4.10-25.71.1 |
| `python3` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 3.4.10-25.71.1 |
| `python3-base` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 3.4.10-25.71.1 |

Products: Fedoraproject Fedora, Oracle Communications Cloud Native Core Network Function Cloud Native Environment, Python Python.

## How do I fix CVE-2020-27619?

Upgrade libpython to a fixed version for your release line: 3.6.13, 3.7.10, 3.8.7 or 3.9.1.

## Is CVE-2020-27619 being exploited?

There is no known exploitation of CVE-2020-27619 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-27619 and fix it if it is affected.

What it is: CVE-2020-27619 is a critical code injection vulnerability in Fedoraproject Fedora, published on 22 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-27619 in the wild and no public exploit code.

Affected packages and fixed versions:
- libpython (Bitnami): affected from 3.0.0; fixed in 3.6.13, 3.7.10, 3.8.7, 3.9.1
- python (Bitnami): affected from 3.0.0; fixed in 3.6.13, 3.7.10, 3.8.7, 3.9.1
- python-min (Bitnami): affected from 3.0.0; fixed in 3.6.13, 3.7.10, 3.8.7, 3.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-27619/ (Markdown: https://insights.sbomify.com/CVE-2020-27619/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-27619
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-27619
- OSV: https://osv.dev/vulnerability/CVE-2020-27619

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-27619/
Summaries are generated and may contain mistakes; the official description above is the record.
