# CVE-2020-27621: Information disclosure in n/a

> The FileImporter extension fails to log user IP addresses correctly, preventing proper audit trails and attribution of user actions.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-mediawiki-2020-27621, GHSA-hh63-773r-23jr

## What is CVE-2020-27621?

CVE-2020-27621 is a medium-severity vulnerability in Mediawiki Mediawiki, published on 22 Oct 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The FileImporter extension in MediaWiki through 1.35.0 was not properly attributing various user actions to a specific user's IP address. Instead, for various actions, it would report the IP address of an internal Wikimedia Foundation server by omitting X-Forwarded-For data. This resulted in an inability to properly audit and attribute various user actions performed via the FileImporter extension.

## Which versions are affected by CVE-2020-27621?

1 open source package ship an affected version, including mediawiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki` | Bitnami | All versions | 1.35.1 |

Products: Mediawiki Mediawiki.

## How do I fix CVE-2020-27621?

Upgrade mediawiki to 1.35.1 or later.

## Is CVE-2020-27621 being exploited?

There is no known exploitation of CVE-2020-27621 in the wild and no public exploit code.

## Other vulnerabilities in Mediawiki Mediawiki

- [CVE-2023-37303](https://insights.sbomify.com/CVE-2023-37303/): Denial of service in n/a (critical 9.8)
- [CVE-2022-29904](https://insights.sbomify.com/CVE-2022-29904/): SQL injection in n/a (critical 9.8)
- [CVE-2022-29906](https://insights.sbomify.com/CVE-2022-29906/): Missing authorization in n/a (critical 9.8)
- [CVE-2022-28205](https://insights.sbomify.com/CVE-2022-28205/): Business logic in n/a (critical 9.8)
- [CVE-2022-28206](https://insights.sbomify.com/CVE-2022-28206/): Missing authorization in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-27621 and fix it if it is affected.

What it is: CVE-2020-27621 is a medium-severity vulnerability in Mediawiki Mediawiki, published on 22 Oct 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-27621 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki (Bitnami): affected all versions; fixed in 1.35.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-27621/ (Markdown: https://insights.sbomify.com/CVE-2020-27621/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-27621
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-27621
- OSV: https://osv.dev/vulnerability/CVE-2020-27621

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-27621/
Summaries are generated and may contain mistakes; the official description above is the record.
