# CVE-2020-27664: Authorization bypass in Strapi

> An attacker can exploit the proxy functionality in Strapi to perform Server-Side Request Forgery attacks, potentially accessing internal resources.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-7frv-9phw-vrvr

## What is CVE-2020-27664?

CVE-2020-27664 is a critical server-side request forgery vulnerability in n/a, published on 22 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

admin/src/containers/InputModalStepperProvider/index.js in Strapi before 3.2.5 has unwanted /proxy?url= functionality.

## Which versions are affected by CVE-2020-27664?

2 open source packages ship an affected version, including strapi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `strapi` | npm | All versions | 3.2.5 |
| `strapi` | npm | All versions | 3.2.5 |

Products: Strapi Strapi.

## How do I fix CVE-2020-27664?

Upgrade strapi to 3.2.5 or later.

## Is CVE-2020-27664 being exploited?

There is no known exploitation of CVE-2020-27664 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-22894](https://insights.sbomify.com/CVE-2023-22894/): Strapi Cleartext Storage of Sensitive Information (high 7.2, exploited in the wild)
- [CVE-2023-22621](https://insights.sbomify.com/CVE-2023-22621/): Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin (critical 10.0)
- [CVE-2022-27263](https://insights.sbomify.com/CVE-2022-27263/): Unrestricted Upload of File with Dangerous Type in Strapi (critical 9.8)
- [CVE-2019-18818](https://insights.sbomify.com/CVE-2019-18818/): Strapi allows unauthenticated attacker to reset admin password without valid reset token (critical 9.8)
- [CVE-2026-22599](https://insights.sbomify.com/CVE-2026-22599/): Strapi Vulnerable to SQL Injection in Content Type Builder (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-27664 and fix it if it is affected.

What it is: CVE-2020-27664 is a critical server-side request forgery vulnerability in n/a, published on 22 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-27664 in the wild and no public exploit code.

Affected packages and fixed versions:
- strapi (npm): affected all versions; fixed in 3.2.5
- strapi (npm): affected all versions; fixed in 3.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-27664/ (Markdown: https://insights.sbomify.com/CVE-2020-27664/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-27664
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-27664
- OSV: https://osv.dev/vulnerability/CVE-2020-27664

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-27664/
Summaries are generated and may contain mistakes; the official description above is the record.
