CVE-2020-2773 Denial of service in Java

Low 3.7 Published Updated

An unauthenticated attacker can cause a partial denial of service in Java SE via network access, affecting both client and server deployments.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-2773?

CVE-2020-2773 is a low-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 15 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Vulnerability in the Java SE, Java SE Embedded product of Oracle Java SE (component: Security). Supported versions that are affected are Java SE: 7u251, 8u241, 11.0.6 and 14; Java SE Embedded: 8u241. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded. Successful attacks of this vulnerability can result in unauthorized ability to cause a partial denial of service (partial DOS) of Java SE, Java SE Embedded. Note: Applies to client and server deployment of Java. This vulnerability can be exploited through sandboxed Java Web Start applications and sandboxed Java applets. It can also be exploited by supplying data to APIs in the specified Component without using sandboxed Java Web Start applications or sandboxed Java applets, such as through a web service. CVSS 3.0 Base Score 3.7 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L).

Which versions are affected by CVE-2020-2773?

3 open source packages ship an affected version, including java, java-min and jre. It affects 21 products.

PackageAffectedFixed in
java BitnamiAll versions1.7.0, 1.8.0, 7.0.261, 8.0.251, 11.0.7, 14.0.1
java-min BitnamiAll versions1.7.0, 1.8.0, 7.0.261, 8.0.251, 11.0.7, 14.0.1
jre BitnamiAll versions1.7.0, 1.8.0, 7.0.261, 8.0.251, 11.0.7, 14.0.1

Products include Canonical Ubuntu Linux, Debian Debian Linux, Fedoraproject Fedora, Mcafee Epolicy Orchestrator, Netapp 7-Mode Transition Tool, Netapp Active Iq Unified Manager and 15 more.

How do I fix CVE-2020-2773?

Upgrade java to a fixed version for your release line: 1.7.0, 1.8.0, 7.0.261 or 8.0.251.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2020-2773 being exploited?

There is no known exploitation of CVE-2020-2773 in the wild and no public exploit code.

All Canonical Ubuntu Linux vulnerabilities

Sources

Also known as BIT-java-2020-2773, BIT-java-min-2020-2773, BIT-jre-2020-2773, CLEANSTART-2026-SW28811, CLEANSTART-2026-ZE28466, DEBIAN-CVE-2020-2773 and 7 more.

Is CVE-2020-2773 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free