{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2020-27745 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2020-27745 is a critical memory corruption vulnerability in Debian Debian Linux, published on 27 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-27745 and fix it if it is affected.\n\nWhat it is: CVE-2020-27745 is a critical memory corruption vulnerability in Debian Debian Linux, published on 27 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-27745 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-27745/ (Markdown: https://insights.sbomify.com/CVE-2020-27745/index.md)","id":"CVE-2020-27745","markdown":"https://insights.sbomify.com/CVE-2020-27745/index.md","name":"CVE-2020-27745","record":{"aliases":["GHSA-v3h5-8p7p-2vrg","SUSE-SU-2021:0155-1","UBUNTU-CVE-2020-27745"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Slurm workload manager","requires_auth":"none","summary":"A buffer overflow in the PMIx MPI plugin of Slurm allows attackers to execute arbitrary code or cause a denial of service.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"slurm","vendor":"schedmd"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-120","name":"Buffer Copy without Checking Size of Input"}],"description":"Slurm before 19.05.8 and 20.x before 20.02.6 has an RPC Buffer Overflow in the PMIx MPI plugin.","ecosystems":["SUSE:Linux Enterprise Module for HPC 12"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2020-27745","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux"],"type":"memory_corruption","year":"2020"},"n_packages":1,"n_references":3,"next":{"headline":"Race condition in n/a","id":"CVE-2020-27746"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for HPC 12","fixed":["17.02.11-6.47.1"],"introduced":["0"],"last_affected":[],"package":"slurm","purl":"pkg:rpm/suse/slurm\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20HPC%2012","source":"SUSE-SU-2021:0155-1"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2020-27744"},"products":["n/a"],"published":"2020-11-27","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"A buffer overflow in the PMIx MPI plugin of Slurm allows attackers to execute arbitrary code or cause a denial of service.","url":"https://insights.sbomify.com/CVE-2020-27745/"}