# CVE-2020-2780: Denial of service in MySQL Server

> A low-privileged attacker can cause a complete denial of service in MySQL Server via network access.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2020
- **Updated:** 30 Sep 2024
- **Also known as:** BIT-mariadb-2020-2780, BIT-mariadb-min-2020-2780, BIT-mysql-client-2020-2780, GHSA-4vxw-fr2r-cwgh, UBUNTU-CVE-2020-2780

## What is CVE-2020-2780?

CVE-2020-2780 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 15 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: DML). Supported versions that are affected are 5.6.47 and prior, 5.7.29 and prior and 8.0.19 and prior. Easily exploitable vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.0 Base Score 6.5 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H).

## Which versions are affected by CVE-2020-2780?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 8 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mariadb` | Bitnami | From 5.5.0 | 5.5.66, 10.1.42, 10.2.28, 10.3.19, 10.4.9 |
| `mariadb-min` | Bitnami | From 5.5.0 | 5.5.66, 10.1.42, 10.2.28, 10.3.19, 10.4.9 |
| `mysql-client` | Bitnami | From 5.5.0 | 5.5.66, 10.1.42, 10.2.28, 10.3.19, 10.4.9 |

Products: Canonical Ubuntu Linux, Fedoraproject Fedora, Mariadb Mariadb, Netapp Active Iq Unified Manager, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation, Netapp Snapcenter, Oracle Mysql.

## How do I fix CVE-2020-2780?

Upgrade mariadb to a fixed version for your release line: 5.5.66, 10.1.42, 10.2.28 or 10.3.19.

## Is CVE-2020-2780 being exploited?

There is no known exploitation of CVE-2020-2780 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2780 and fix it if it is affected.

What it is: CVE-2020-2780 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 15 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-2780 in the wild and no public exploit code.

Affected packages and fixed versions:
- mariadb (Bitnami): affected from 5.5.0; fixed in 5.5.66, 10.1.42, 10.2.28, 10.3.19, 10.4.9
- mariadb-min (Bitnami): affected from 5.5.0; fixed in 5.5.66, 10.1.42, 10.2.28, 10.3.19, 10.4.9
- mysql-client (Bitnami): affected from 5.5.0; fixed in 5.5.66, 10.1.42, 10.2.28, 10.3.19, 10.4.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2780/ (Markdown: https://insights.sbomify.com/CVE-2020-2780/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2780
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2780
- OSV: https://osv.dev/vulnerability/CVE-2020-2780

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2780/
Summaries are generated and may contain mistakes; the official description above is the record.
