# CVE-2020-27998: Missing Authorization in FastReport

> FastReport library lacks script security, allowing attackers to execute arbitrary code via unsafe reflection and dynamic loading functions.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-v726-3vg9-cp34

## What is CVE-2020-27998?

CVE-2020-27998 is a critical code injection vulnerability in n/a, published on 29 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in FastReport before 2020.4.0. It lacks a ScriptSecurity feature and therefore may mishandle (for example) GetType, typeof, TypeOf, DllImport, LoadLibrary, and GetProcAddress.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2020-27998?

2 open source packages ship an affected version, including FastReport.OpenSource. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `FastReport.OpenSource` | NuGet | All versions | 2020.4.0 |
| `FastReport.OpenSource` | NuGet | All versions | 2020.4.0 |

Products: Fast-Report Fastreport.

## How do I fix CVE-2020-27998?

Upgrade FastReport.OpenSource to 2020.4.0 or later.

## Is CVE-2020-27998 being exploited?

There is no known exploitation of CVE-2020-27998 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-27998 and fix it if it is affected.

What it is: CVE-2020-27998 is a critical code injection vulnerability in n/a, published on 29 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-27998 in the wild and no public exploit code.

Affected packages and fixed versions:
- FastReport.OpenSource (NuGet): affected all versions; fixed in 2020.4.0
- FastReport.OpenSource (NuGet): affected all versions; fixed in 2020.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-27998/ (Markdown: https://insights.sbomify.com/CVE-2020-27998/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-27998
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-27998
- OSV: https://osv.dev/vulnerability/CVE-2020-27998

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-27998/
Summaries are generated and may contain mistakes; the official description above is the record.
