CVE-2020-2800 Missing authorization in Java
An unauthenticated attacker can access and modify data via the Java SE Lightweight HTTP Server component.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-2800?
CVE-2020-2800 is a medium-severity missing authorization vulnerability in Canonical Ubuntu Linux, published on 15 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Vulnerability in the Java SE, Java SE Embedded product of Oracle Java SE (component: Lightweight HTTP Server). Supported versions that are affected are Java SE: 7u251, 8u241, 11.0.6 and 14; Java SE Embedded: 8u241. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of Java SE, Java SE Embedded accessible data as well as unauthorized read access to a subset of Java SE, Java SE Embedded accessible data. Note: This vulnerability can only be exploited by supplying data to APIs in the specified Component without using Untrusted Java Web Start applications or Untrusted Java applets, such as through a web service. CVSS 3.0 Base Score 4.8 (Confidentiality and Integrity impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N).
Which versions are affected by CVE-2020-2800?
3 open source packages ship an affected version, including java, java-min and jre. It affects 20 products.
| Package | Affected | Fixed in |
|---|---|---|
java Bitnami | All versions | 1.7.0, 1.8.0, 7.0.261, 8.0.251, 11.0.7, 14.0.1 |
java-min Bitnami | All versions | 1.7.0, 1.8.0, 7.0.261, 8.0.251, 11.0.7, 14.0.1 |
jre Bitnami | All versions | 1.7.0, 1.8.0, 7.0.261, 8.0.251, 11.0.7, 14.0.1 |
Products include Canonical Ubuntu Linux, Debian Debian Linux, Fedoraproject Fedora, Netapp 7-Mode Transition Tool, Netapp Active Iq Unified Manager, Netapp Cloud Backup and 14 more.
How do I fix CVE-2020-2800?
Upgrade java to a fixed version for your release line: 1.7.0, 1.8.0, 7.0.261 or 8.0.251.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2020-2800 being exploited?
There is no known exploitation of CVE-2020-2800 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as BIT-java-2020-2800, BIT-java-min-2020-2800, BIT-jre-2020-2800, CLEANSTART-2026-FF99068, CLEANSTART-2026-LH78467, DEBIAN-CVE-2020-2800 and 7 more.