{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 3 products.","exploited":"There is no known exploitation of CVE-2020-28032 in the wild and no public exploit code.","fix":"Upgrade wordpress to 5.5.2 or later.","what":"CVE-2020-28032 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 31 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-28032 and fix it if it is affected.\n\nWhat it is: CVE-2020-28032 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 31 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-28032 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected all versions; fixed in 5.5.2\n- wordpress-multisite (Bitnami): affected all versions; fixed in 5.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-28032/ (Markdown: https://insights.sbomify.com/CVE-2020-28032/index.md)","id":"CVE-2020-28032","markdown":"https://insights.sbomify.com/CVE-2020-28032/index.md","name":"CVE-2020-28032","record":{"aliases":["BIT-wordpress-2020-28032","BIT-wordpress-multisite-2020-28032","DEBIAN-CVE-2020-28032","GHSA-546f-q8mw-j4qj","UBUNTU-CVE-2020-28032"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress core","requires_auth":"none","summary":"WordPress mishandles deserialization requests, potentially allowing attackers to execute arbitrary code on the server.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"wordpress","vendor":"wordpress"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"WordPress before 5.5.2 mishandles deserialization requests in wp-includes/Requests/Utility/FilteredIterator.php.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2021-11-17","github_poc":1,"max_poc_stars":4,"metasploit":0,"nuclei":0,"refs":[{"date":"2021-11-17T07:09:47Z","kind":"github_poc","ref":"https://github.com/nth347/CVE-2020-28032_PoC","stars":4,"title":"PoC for CVE-2020-28032 (It's just a POP chain in WordPress \u003c 5.5.2 for exploiting PHP Object Injection)"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Deserialization in n/a","id":"CVE-2020-28032","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora","wordpress:wordpress"],"type":"deserialization","year":"2020"},"n_packages":2,"n_references":8,"next":{"headline":"Business logic in n/a","id":"CVE-2020-28033"},"packages":[{"ecosystem":"Bitnami","fixed":["5.5.2"],"introduced":["0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2020-28032"},{"ecosystem":"Bitnami","fixed":["5.5.2"],"introduced":["0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2020-28032"}],"prev":{"headline":"Other in n/a","id":"CVE-2020-28031"},"products":["n/a"],"published":"2020-10-31","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"WordPress mishandles deserialization requests, potentially allowing attackers to execute arbitrary code on the server.","url":"https://insights.sbomify.com/CVE-2020-28032/"}