# CVE-2020-28032: Deserialization in n/a

> WordPress mishandles deserialization requests, potentially allowing attackers to execute arbitrary code on the server.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-wordpress-2020-28032, BIT-wordpress-multisite-2020-28032, DEBIAN-CVE-2020-28032, GHSA-546f-q8mw-j4qj, UBUNTU-CVE-2020-28032

## What is CVE-2020-28032?

CVE-2020-28032 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 31 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

WordPress before 5.5.2 mishandles deserialization requests in wp-includes/Requests/Utility/FilteredIterator.php.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2020-28032?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wordpress` | Bitnami | All versions | 5.5.2 |
| `wordpress-multisite` | Bitnami | All versions | 5.5.2 |

Products: Debian Debian Linux, Fedoraproject Fedora, Wordpress Wordpress.

## How do I fix CVE-2020-28032?

Upgrade wordpress to 5.5.2 or later.

## Is CVE-2020-28032 being exploited?

There is no known exploitation of CVE-2020-28032 in the wild and no public exploit code.

Public exploit code:

- PoC for CVE-2020-28032 (It's just a POP chain in WordPress < 5.5.2 for exploiting PHP Object Injection) (github_poc): https://github.com/nth347/CVE-2020-28032_PoC

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-28032 and fix it if it is affected.

What it is: CVE-2020-28032 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 31 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-28032 in the wild and no public exploit code.

Affected packages and fixed versions:
- wordpress (Bitnami): affected all versions; fixed in 5.5.2
- wordpress-multisite (Bitnami): affected all versions; fixed in 5.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-28032/ (Markdown: https://insights.sbomify.com/CVE-2020-28032/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-28032
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-28032
- OSV: https://osv.dev/vulnerability/CVE-2020-28032

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-28032/
Summaries are generated and may contain mistakes; the official description above is the record.
