# CVE-2020-28033: Business logic in n/a

> Attackers can inject spam embeds from disabled sites in WordPress multisite networks, requiring site administrators to upgrade.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-wordpress-2020-28033, BIT-wordpress-multisite-2020-28033, DEBIAN-CVE-2020-28033, GHSA-chfm-w5r6-r24m, UBUNTU-CVE-2020-28033

## What is CVE-2020-28033?

CVE-2020-28033 is a high-severity vulnerability in Debian Debian Linux, published on 31 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

WordPress before 5.5.2 mishandles embeds from disabled sites on a multisite network, as demonstrated by allowing a spam embed.

## Which versions are affected by CVE-2020-28033?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wordpress` | Bitnami | All versions | 5.5.2 |
| `wordpress-multisite` | Bitnami | All versions | 5.5.2 |

Products: Debian Debian Linux, Fedoraproject Fedora, Wordpress Wordpress.

## How do I fix CVE-2020-28033?

Upgrade wordpress to 5.5.2 or later.

## Is CVE-2020-28033 being exploited?

There is no known exploitation of CVE-2020-28033 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-28033 and fix it if it is affected.

What it is: CVE-2020-28033 is a high-severity vulnerability in Debian Debian Linux, published on 31 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-28033 in the wild and no public exploit code.

Affected packages and fixed versions:
- wordpress (Bitnami): affected all versions; fixed in 5.5.2
- wordpress-multisite (Bitnami): affected all versions; fixed in 5.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-28033/ (Markdown: https://insights.sbomify.com/CVE-2020-28033/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-28033
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-28033
- OSV: https://osv.dev/vulnerability/CVE-2020-28033

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-28033/
Summaries are generated and may contain mistakes; the official description above is the record.
