{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 3 products.","exploited":"There is no known exploitation of CVE-2020-28039 in the wild and no public exploit code.","fix":"Upgrade wordpress to 5.5.2 or later.","what":"CVE-2020-28039 is a critical path traversal vulnerability in Canonical Ubuntu Linux, published on 31 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-28039 and fix it if it is affected.\n\nWhat it is: CVE-2020-28039 is a critical path traversal vulnerability in Canonical Ubuntu Linux, published on 31 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-28039 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected all versions; fixed in 5.5.2\n- wordpress-multisite (Bitnami): affected all versions; fixed in 5.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-28039/ (Markdown: https://insights.sbomify.com/CVE-2020-28039/index.md)","id":"CVE-2020-28039","markdown":"https://insights.sbomify.com/CVE-2020-28039/index.md","name":"CVE-2020-28039","record":{"aliases":["BIT-wordpress-2020-28039","BIT-wordpress-multisite-2020-28039","DEBIAN-CVE-2020-28039","GHSA-65h5-8qpr-9m3v","UBUNTU-CVE-2020-28039"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress core","requires_auth":"none","summary":"Attackers can delete arbitrary files due to improper meta key protection checks in WordPress.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"wordpress","vendor":"wordpress"}],"cvss":{"score":9.1,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H","version":"3.1"},"cwes":[],"description":"is_protected_meta in wp-includes/meta.php in WordPress before 5.5.2 allows arbitrary file deletion because it does not properly determine whether a meta key is considered protected.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Path traversal in n/a","id":"CVE-2020-28039","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux","wordpress:wordpress"],"type":"path_traversal","year":"2020"},"n_packages":2,"n_references":8,"next":{"headline":"WordPress before 5.5.2 allows CSRF attacks that change a theme's background image.","id":"CVE-2020-28040"},"packages":[{"ecosystem":"Bitnami","fixed":["5.5.2"],"introduced":["0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2020-28039"},{"ecosystem":"Bitnami","fixed":["5.5.2"],"introduced":["0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2020-28039"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2020-28038"},"products":["n/a"],"published":"2020-10-31","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can delete arbitrary files due to improper meta key protection checks in WordPress.","url":"https://insights.sbomify.com/CVE-2020-28039/"}