{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 3 products.","exploited":"There is no known exploitation of CVE-2020-28040 in the wild and no public exploit code.","fix":"Upgrade wordpress to 5.5.2 or later.","what":"CVE-2020-28040 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 31 Oct 2020."},"fix_prompt":"Check this codebase for CVE-2020-28040 and fix it if it is affected.\n\nWhat it is: CVE-2020-28040 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 31 Oct 2020. \nExploitation: There is no known exploitation of CVE-2020-28040 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected all versions; fixed in 5.5.2\n- wordpress-multisite (Bitnami): affected all versions; fixed in 5.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-28040/ (Markdown: https://insights.sbomify.com/CVE-2020-28040/index.md)","id":"CVE-2020-28040","markdown":"https://insights.sbomify.com/CVE-2020-28040/index.md","name":"CVE-2020-28040","record":{"aliases":["BIT-wordpress-2020-28040","BIT-wordpress-multisite-2020-28040","DEBIAN-CVE-2020-28040","GHSA-86pg-877h-rfr2","UBUNTU-CVE-2020-28040"],"analysis":null,"analysis_generated_by":null,"assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"wordpress","vendor":"wordpress"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"WordPress before 5.5.2 allows CSRF attacks that change a theme's background image.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WordPress before 5.5.2 allows CSRF attacks that change a theme's background image.","id":"CVE-2020-28040","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux","wordpress:wordpress"],"type":null,"year":"2020"},"n_packages":2,"n_references":7,"next":{"headline":"Server-side request forgery in n/a","id":"CVE-2020-28041"},"packages":[{"ecosystem":"Bitnami","fixed":["5.5.2"],"introduced":["0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2020-28040"},{"ecosystem":"Bitnami","fixed":["5.5.2"],"introduced":["0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2020-28040"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2020-28039"},"products":["n/a"],"published":"2020-10-31","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2020-28040/"}