# CVE-2020-28040: WordPress before 5.5.2 allows CSRF attacks that change a theme's background image.


- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 31 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-wordpress-2020-28040, BIT-wordpress-multisite-2020-28040, DEBIAN-CVE-2020-28040, GHSA-86pg-877h-rfr2, UBUNTU-CVE-2020-28040

## What is CVE-2020-28040?

CVE-2020-28040 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 31 Oct 2020. 

### Official description

WordPress before 5.5.2 allows CSRF attacks that change a theme's background image.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2020-28040?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wordpress` | Bitnami | All versions | 5.5.2 |
| `wordpress-multisite` | Bitnami | All versions | 5.5.2 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Wordpress Wordpress.

## How do I fix CVE-2020-28040?

Upgrade wordpress to 5.5.2 or later.

## Is CVE-2020-28040 being exploited?

There is no known exploitation of CVE-2020-28040 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-28040 and fix it if it is affected.

What it is: CVE-2020-28040 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 31 Oct 2020. 
Exploitation: There is no known exploitation of CVE-2020-28040 in the wild and no public exploit code.

Affected packages and fixed versions:
- wordpress (Bitnami): affected all versions; fixed in 5.5.2
- wordpress-multisite (Bitnami): affected all versions; fixed in 5.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-28040/ (Markdown: https://insights.sbomify.com/CVE-2020-28040/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-28040
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-28040
- OSV: https://osv.dev/vulnerability/CVE-2020-28040

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-28040/
Summaries are generated and may contain mistakes; the official description above is the record.
