# CVE-2020-28053: Privilege Escalation in HashiCorp Consul

> Operators with read permissions can access the Connect CA private key configuration, potentially compromising service mesh security.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-consul-2020-28053, DEBIAN-CVE-2020-28053, GHSA-6m72-467w-94rh, GO-2024-2505, UBUNTU-CVE-2020-28053

## What is CVE-2020-28053?

CVE-2020-28053 is a medium-severity vulnerability in n/a, published on 23 Nov 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

HashiCorp Consul and Consul Enterprise 1.2.0 up to 1.8.5 allowed operators with operator:read ACL permissions to read the Connect CA private key configuration. Fixed in 1.6.10, 1.7.10, and 1.8.6.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2020-28053?

8 open source packages ship an affected version, including github.com/hashicorp/consul and consul. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/consul` | Go | From 1.2.0 | 1.6.10, 1.7.10, 1.8.6 |
| `github.com/hashicorp/consul` | Go | From 1.2.0 | 1.6.10 |
| `github.com/hashicorp/consul` | Go | From 1.2.0 | 1.6.10 |
| `github.com/hashicorp/consul` | Go | From 1.7.0 | 1.7.10 |
| `github.com/hashicorp/consul` | Go | From 1.7.0 | 1.7.10 |
| `github.com/hashicorp/consul` | Go | From 1.8.0 | 1.8.6 |
| `github.com/hashicorp/consul` | Go | From 1.8.0 | 1.8.6 |
| `consul` | Bitnami | From 1.2.0 | 1.6.10, 1.7.10, 1.8.6 |

Products: Hashicorp Consul.

## How do I fix CVE-2020-28053?

Upgrade github.com/hashicorp/consul to a fixed version for your release line: 1.6.10, 1.7.10 or 1.8.6.

## Is CVE-2020-28053 being exploited?

There is no known exploitation of CVE-2020-28053 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-41805](https://insights.sbomify.com/CVE-2021-41805/): Privilege escalation in n/a (high 8.8)
- [CVE-2021-37219](https://insights.sbomify.com/CVE-2021-37219/): HashiCorp Consul Privilege Escalation Vulnerability (high 8.8)
- [CVE-2023-2816](https://insights.sbomify.com/CVE-2023-2816/): Consul Envoy Extension Downsteam Proxy Configuration By Upstream Service Owner (high 8.7)
- [CVE-2024-10006](https://insights.sbomify.com/CVE-2024-10006/): Consul L7 Intentions Vulnerable To Headers Bypass (high 8.3)
- [CVE-2024-10005](https://insights.sbomify.com/CVE-2024-10005/): Consul L7 Intentions Vulnerable To URL Path Bypass (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-28053 and fix it if it is affected.

What it is: CVE-2020-28053 is a medium-severity vulnerability in n/a, published on 23 Nov 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-28053 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/consul (Go): affected from 1.2.0; fixed in 1.6.10, 1.7.10, 1.8.6
- github.com/hashicorp/consul (Go): affected from 1.2.0; fixed in 1.6.10
- github.com/hashicorp/consul (Go): affected from 1.2.0; fixed in 1.6.10
- github.com/hashicorp/consul (Go): affected from 1.7.0; fixed in 1.7.10
- github.com/hashicorp/consul (Go): affected from 1.7.0; fixed in 1.7.10
- github.com/hashicorp/consul (Go): affected from 1.8.0; fixed in 1.8.6
- github.com/hashicorp/consul (Go): affected from 1.8.0; fixed in 1.8.6
- consul (Bitnami): affected from 1.2.0; fixed in 1.6.10, 1.7.10, 1.8.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-28053/ (Markdown: https://insights.sbomify.com/CVE-2020-28053/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-28053
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-28053
- OSV: https://osv.dev/vulnerability/CVE-2020-28053

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-28053/
Summaries are generated and may contain mistakes; the official description above is the record.
