CVE-2020-2816 Vulnerability in the Java SE product of Oracle Java SE (component: JSSE).
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2020-2816?
CVE-2020-2816 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 15 Apr 2020.
Official description
Vulnerability in the Java SE product of Oracle Java SE (component: JSSE). Supported versions that are affected are Java SE: 11.0.6 and 14. Easily exploitable vulnerability allows unauthenticated attacker with network access via HTTPS to compromise Java SE. Successful attacks of this vulnerability can result in unauthorized creation, deletion or modification access to critical data or all Java SE accessible data. Note: This vulnerability can only be exploited by supplying data to APIs in the specified Component without using Untrusted Java Web Start applications or Untrusted Java applets, such as through a web service. CVSS 3.0 Base Score 7.5 (Integrity impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N).
Which versions are affected by CVE-2020-2816?
3 open source packages ship an affected version, including java, java-min and jre. It affects 19 products.
| Package | Affected | Fixed in |
|---|---|---|
java Bitnami | From 9.0.0 | 11.0.7, 14.0.1 |
java-min Bitnami | From 9.0.0 | 11.0.7, 14.0.1 |
jre Bitnami | From 9.0.0 | 11.0.7, 14.0.1 |
Products include Canonical Ubuntu Linux, Debian Debian Linux, Netapp 7-Mode Transition Tool, Netapp Active Iq Unified Manager, Netapp Cloud Backup, Netapp E-Series Performance Analyzer and 13 more.
How do I fix CVE-2020-2816?
Upgrade java to a fixed version for your release line: 11.0.7 or 14.0.1.
Is CVE-2020-2816 being exploited?
There is no known exploitation of CVE-2020-2816 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as BIT-java-2020-2816, BIT-java-min-2020-2816, BIT-jre-2020-2816, CLEANSTART-2026-QE65271, DEBIAN-CVE-2020-2816, GHSA-wq43-mwf7-pm7c and 5 more.