# CVE-2020-2816: Vulnerability in the Java SE product of Oracle Java SE (component: JSSE).


- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 15 Apr 2020
- **Updated:** 27 Sep 2024
- **Also known as:** BIT-java-2020-2816, BIT-java-min-2020-2816, BIT-jre-2020-2816, CLEANSTART-2026-QE65271, DEBIAN-CVE-2020-2816, GHSA-wq43-mwf7-pm7c, MINI-82gf-cwjw-pwwx, MINI-94j8-fq3x-hg78, MINI-gww6-874x-vfm2, MINI-hc48-mwj8-h4vp, UBUNTU-CVE-2020-2816

## What is CVE-2020-2816?

CVE-2020-2816 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 15 Apr 2020. 

### Official description

Vulnerability in the Java SE product of Oracle Java SE (component: JSSE). Supported versions that are affected are Java SE: 11.0.6 and 14. Easily exploitable vulnerability allows unauthenticated attacker with network access via HTTPS to compromise Java SE. Successful attacks of this vulnerability can result in unauthorized creation, deletion or modification access to critical data or all Java SE accessible data. Note: This vulnerability can only be exploited by supplying data to APIs in the specified Component without using Untrusted Java Web Start applications or Untrusted Java applets, such as through a web service. CVSS 3.0 Base Score 7.5 (Integrity impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N).

## Which versions are affected by CVE-2020-2816?

3 open source packages ship an affected version, including java, java-min and jre. It affects 19 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `java` | Bitnami | From 9.0.0 | 11.0.7, 14.0.1 |
| `java-min` | Bitnami | From 9.0.0 | 11.0.7, 14.0.1 |
| `jre` | Bitnami | From 9.0.0 | 11.0.7, 14.0.1 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Netapp 7-Mode Transition Tool, Netapp Active Iq Unified Manager, Netapp Cloud Backup, Netapp E-Series Performance Analyzer, Netapp E-Series Santricity Os Controller, Netapp E-Series Santricity Web Services, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation, Netapp Plug-in for Symantec Netbackup, Netapp Santricity Unified Manager, Netapp Snapmanager, Netapp Steelstore Cloud Integrated Storage, Netapp Storagegrid, Opensuse Leap, Oracle Jdk, Oracle Jre, Oracle Openjdk.

## How do I fix CVE-2020-2816?

Upgrade java to a fixed version for your release line: 11.0.7 or 14.0.1.

## Is CVE-2020-2816 being exploited?

There is no known exploitation of CVE-2020-2816 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2816 and fix it if it is affected.

What it is: CVE-2020-2816 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 15 Apr 2020. 
Exploitation: There is no known exploitation of CVE-2020-2816 in the wild and no public exploit code.

Affected packages and fixed versions:
- java (Bitnami): affected from 9.0.0; fixed in 11.0.7, 14.0.1
- java-min (Bitnami): affected from 9.0.0; fixed in 11.0.7, 14.0.1
- jre (Bitnami): affected from 9.0.0; fixed in 11.0.7, 14.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2816/ (Markdown: https://insights.sbomify.com/CVE-2020-2816/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2816
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2816
- OSV: https://osv.dev/vulnerability/CVE-2020-2816

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2816/
Summaries are generated and may contain mistakes; the official description above is the record.
