# CVE-2020-28248: Integer Overflow in png-img

> An integer overflow in the png-img library leads to heap buffer overflow, allowing remote code execution via crafted PNG files.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Feb 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-q5wr-fvpq-p67g

## What is CVE-2020-28248?

CVE-2020-28248 is a high-severity vulnerability in n/a, published on 19 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An integer overflow in the PngImg::InitStorage_() function of png-img before 3.1.0 leads to an under-allocation of heap memory and subsequently an exploitable heap-based buffer overflow when loading a crafted PNG file.

Weakness: CWE-787 (Out-of-bounds Write), CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2020-28248?

2 open source packages ship an affected version, including png-img. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `png-img` | npm | All versions | 3.1.0 |
| `png-img` | npm | All versions | 3.1.0 |

Products: Png-Img Project Png-Img.

## How do I fix CVE-2020-28248?

Upgrade png-img to 3.1.0 or later.

## Is CVE-2020-28248 being exploited?

There is no known exploitation of CVE-2020-28248 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-28248 and fix it if it is affected.

What it is: CVE-2020-28248 is a high-severity vulnerability in n/a, published on 19 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-28248 in the wild and no public exploit code.

Affected packages and fixed versions:
- png-img (npm): affected all versions; fixed in 3.1.0
- png-img (npm): affected all versions; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-28248/ (Markdown: https://insights.sbomify.com/CVE-2020-28248/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-28248
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-28248
- OSV: https://osv.dev/vulnerability/CVE-2020-28248

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-28248/
Summaries are generated and may contain mistakes; the official description above is the record.
