{"answers":{"affected":"2 open source packages ship an affected version, including golang and stdlib. It affects 4 products.","exploited":"There is no known exploitation of CVE-2020-28362 in the wild and no public exploit code.","fix":"Upgrade golang to a fixed version for your release line: 1.14.12 or 1.15.5.","what":"CVE-2020-28362 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 18 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-28362 and fix it if it is affected.\n\nWhat it is: CVE-2020-28362 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 18 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-28362 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- golang (Bitnami): affected all versions; fixed in 1.14.12, 1.15.5\n- stdlib (Go): affected from 1.14.0-0; fixed in 1.14.12, 1.15.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-28362/ (Markdown: https://insights.sbomify.com/CVE-2020-28362/index.md)","id":"CVE-2020-28362","markdown":"https://insights.sbomify.com/CVE-2020-28362/index.md","name":"CVE-2020-28362","record":{"aliases":["AZL-79068","AZL-98991","BIT-golang-2020-28362","DEBIAN-CVE-2020-28362","GHSA-gff4-9rfx-4pcw","GO-2021-0069","RHBA-2021:0482","UBUNTU-CVE-2020-28362"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Go standard library","requires_auth":"none","summary":"A flaw in the Go standard library allows attackers to cause a denial of service, requiring developers to upgrade their Go runtime.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"go","vendor":"golang"},{"product":"cloud_insights_telegraf_agent","vendor":"netapp"},{"product":"trident","vendor":"netapp"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"Go before 1.14.12 and 1.15.x before 1.15.4 allows Denial of Service.","ecosystems":["Bitnami","Go","Red Hat:service_mesh:2.0::el8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2020-28362","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"fedoraproject:fedora","products":["fedoraproject:fedora","golang:go"],"type":"denial_of_service","year":"2020"},"n_packages":3,"n_references":6,"next":{"headline":"Locust Stored Cross-site Scripting Vulnerability","id":"CVE-2020-28364"},"packages":[{"ecosystem":"Bitnami","fixed":["1.14.12","1.15.5"],"introduced":["0","1.15.0"],"last_affected":[],"package":"golang","purl":"pkg:bitnami/golang","source":"BIT-golang-2020-28362"},{"ecosystem":"Go","fixed":["1.14.12","1.15.5"],"introduced":["1.14.0-0","1.15.0-0"],"last_affected":[],"package":"stdlib","purl":"pkg:golang/stdlib","source":"GO-2021-0069"},{"ecosystem":"Red Hat:service_mesh:2.0::el8","fixed":["0:v1.24.4.redhat2-1.el8"],"introduced":["0"],"last_affected":[],"package":"kiali","purl":"pkg:rpm/redhat/kiali","source":"RHBA-2021:0482"}],"prev":{"headline":"Security feature bypass in n/a","id":"CVE-2020-28361"},"products":["n/a"],"published":"2020-11-18","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHBA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"A flaw in the Go standard library allows attackers to cause a denial of service, requiring developers to upgrade their Go runtime.","url":"https://insights.sbomify.com/CVE-2020-28362/"}