# CVE-2020-28364: Locust Stored Cross-site Scripting Vulnerability


- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 9 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-vqxw-9pg7-v7v9, PYSEC-2020-60

## What is CVE-2020-28364?

CVE-2020-28364 is a medium-severity vulnerability in n/a, published on 9 Nov 2020. 

### Official description

A stored cross-site scripting (XSS) vulnerability affects the Web UI in Locust before 1.3.2, if the installation violates the usage expectations by exposing this UI to outside users.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-28364?

3 open source packages ship an affected version, including locust. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `locust` | PyPI | All versions | 1.3.2 |
| `locust` | PyPI | All versions | 1.3.2 |
| `locust` | PyPI | All versions | 1.3.2 |

Products: Locust Locust.

## How do I fix CVE-2020-28364?

Upgrade locust to 1.3.2 or later.

## Is CVE-2020-28364 being exploited?

There is no known exploitation of CVE-2020-28364 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-28364 and fix it if it is affected.

What it is: CVE-2020-28364 is a medium-severity vulnerability in n/a, published on 9 Nov 2020. 
Exploitation: There is no known exploitation of CVE-2020-28364 in the wild and no public exploit code.

Affected packages and fixed versions:
- locust (PyPI): affected all versions; fixed in 1.3.2
- locust (PyPI): affected all versions; fixed in 1.3.2
- locust (PyPI): affected all versions; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-28364/ (Markdown: https://insights.sbomify.com/CVE-2020-28364/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-28364
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-28364
- OSV: https://osv.dev/vulnerability/CVE-2020-28364

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-28364/
Summaries are generated and may contain mistakes; the official description above is the record.
