# CVE-2020-28441: Prototype Pollution

> Attackers can pollute the prototype via malicious INI files, potentially leading to code execution or privilege escalation in applications using this library.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jul 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-m6mg-jvjf-w44x

## What is CVE-2020-28441?

CVE-2020-28441 is a high-severity vulnerability in conf-cfg-ini, published on 25 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects the package conf-cfg-ini before 1.2.2. If an attacker submits a malicious INI file to an application that parses it with decode, they will pollute the prototype on the application. This can be exploited further depending on the context.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2020-28441?

2 open source packages ship an affected version, including conf-cfg-ini. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `conf-cfg-ini` | npm | All versions | 1.2.2 |
| `conf-cfg-ini` | npm | All versions | 1.2.2 |

Products: Conf-Cfg-Ini Project Conf-Cfg-Ini.

## How do I fix CVE-2020-28441?

Upgrade conf-cfg-ini to 1.2.2 or later.

## Is CVE-2020-28441 being exploited?

There is no known exploitation of CVE-2020-28441 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-28441 and fix it if it is affected.

What it is: CVE-2020-28441 is a high-severity vulnerability in conf-cfg-ini, published on 25 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-28441 in the wild and no public exploit code.

Affected packages and fixed versions:
- conf-cfg-ini (npm): affected all versions; fixed in 1.2.2
- conf-cfg-ini (npm): affected all versions; fixed in 1.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-28441/ (Markdown: https://insights.sbomify.com/CVE-2020-28441/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-28441
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-28441
- OSV: https://osv.dev/vulnerability/CVE-2020-28441

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-28441/
Summaries are generated and may contain mistakes; the official description above is the record.
