# CVE-2020-28460: Prototype Pollution

> Prototype pollution in multi-ini allows attackers to modify object prototypes, potentially leading to code execution or privilege escalation.

- **Severity:** Medium 5.6 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:R`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Dec 2020
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-67mq-h2r9-rh2m, SNYK-JS-MULTIINI-1053229

## What is CVE-2020-28460?

CVE-2020-28460 is a medium-severity vulnerability in multi-ini, published on 22 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects the package multi-ini before 2.1.2. It is possible to pollute an object's prototype by specifying the constructor.proto object as part of an array. This is a bypass of CVE-2020-28448.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2020-28460?

2 open source packages ship an affected version, including multi-ini. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `multi-ini` | npm | All versions | 2.1.2 |
| `multi-ini` | npm | All versions | 2.1.2 |

Products: Multi-Ini Project Multi-Ini.

## How do I fix CVE-2020-28460?

Upgrade multi-ini to 2.1.2 or later.

## Is CVE-2020-28460 being exploited?

There is no known exploitation of CVE-2020-28460 in the wild and no public exploit code.

## Other vulnerabilities in multi-ini

- [CVE-2020-28448](https://insights.sbomify.com/CVE-2020-28448/): Prototype Pollution (medium 5.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-28460 and fix it if it is affected.

What it is: CVE-2020-28460 is a medium-severity vulnerability in multi-ini, published on 22 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-28460 in the wild and no public exploit code.

Affected packages and fixed versions:
- multi-ini (npm): affected all versions; fixed in 2.1.2
- multi-ini (npm): affected all versions; fixed in 2.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-28460/ (Markdown: https://insights.sbomify.com/CVE-2020-28460/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-28460
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-28460
- OSV: https://osv.dev/vulnerability/CVE-2020-28460

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-28460/
Summaries are generated and may contain mistakes; the official description above is the record.
