# CVE-2020-28463: Server-side Request Forgery (SSRF)

> An attacker can trigger Server-side Request Forgery in ReportLab by injecting malicious img tags into documents, allowing internal network access.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Feb 2021
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2020-28463, GHSA-mpvw-25mg-59vx, MGASA-2021-0521, OESA-2022-1887, PYSEC-2021-146, SNYK-PYTHON-REPORTLAB-1022145, SUSE-SU-2021:3209-1, UBUNTU-CVE-2020-28463, openSUSE-SU-2021:1147-1, openSUSE-SU-2021:2641-1

## What is CVE-2020-28463?

CVE-2020-28463 is a medium-severity server-side request forgery vulnerability in Fedoraproject Fedora, published on 18 Feb 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

All versions of package reportlab are vulnerable to Server-side Request Forgery (SSRF) via img tags. In order to reduce risk, use trustedSchemes & trustedHosts (see in Reportlab's documentation) Steps to reproduce by Karan Bamal: 1. Download and install the latest package of reportlab 2. Go to demos -> odyssey -> dodyssey 3. In the text file odyssey.txt that needs to be converted to pdf inject <img src="http://127.0.0.1:5000" valign="top"/> 4. Create a nc listener nc -lp 5000 5. Run python3 dodyssey.py 6. You will get a hit on your nc showing we have successfully proceded to send a server side request 7. dodyssey.py will show error since there is no img file on the url, but we are able to do SSRF

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2020-28463?

3 open source packages ship an affected version, including reportlab. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `reportlab` | PyPI | All versions | 3.5.55 |
| `reportlab` | PyPI | All versions | 3.5.55 |
| `reportlab` | PyPI | All versions | 3.5.55 |
| `python-reportlab` | SUSE:Linux Enterprise Workstation Extension 12 SP5 | All versions | 2.7-3.8.1 |
| `python-reportlab` | openSUSE:Leap 15.2 | All versions | 3.4.0-lp152.5.3.1 |
| `python-reportlab` | openSUSE:Leap 15.3 | All versions | 3.4.0-3.6.1 |

Products: Fedoraproject Fedora, Reportlab Reportlab.

## How do I fix CVE-2020-28463?

Upgrade reportlab to 3.5.55 or later.

## Is CVE-2020-28463 being exploited?

There is no known exploitation of CVE-2020-28463 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-28463 and fix it if it is affected.

What it is: CVE-2020-28463 is a medium-severity server-side request forgery vulnerability in Fedoraproject Fedora, published on 18 Feb 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-28463 in the wild and no public exploit code.

Affected packages and fixed versions:
- reportlab (PyPI): affected all versions; fixed in 3.5.55
- reportlab (PyPI): affected all versions; fixed in 3.5.55
- reportlab (PyPI): affected all versions; fixed in 3.5.55

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-28463/ (Markdown: https://insights.sbomify.com/CVE-2020-28463/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-28463
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-28463
- OSV: https://osv.dev/vulnerability/CVE-2020-28463

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-28463/
Summaries are generated and may contain mistakes; the official description above is the record.
