# CVE-2020-28466: Denial of Service (DoS)

> Untrusted accounts can crash the NATS server by exploiting service export/import cycles, causing a denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2021
- **Updated:** 16 Sep 2024
- **Also known as:** BIT-nats-2020-28466, GHSA-m4jx-6526-vvhm, GO-2022-0855, SNYK-GOLANG-GITHUBCOMNATSIONATSSERVERSERVER-1042967

## What is CVE-2020-28466?

CVE-2020-28466 is a high-severity denial of service vulnerability in github.com/nats-io/nats-server/server, published on 7 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects all versions of package github.com/nats-io/nats-server/server. Untrusted accounts are able to crash the server using configs that represent a service export/import cycles. Disclaimer from the maintainers: Running a NATS service which is exposed to untrusted users presents a heightened risk. Any remote execution flaw or equivalent seriousness, or denial-of-service by unauthenticated users, will lead to prompt releases by the NATS maintainers. Fixes for denial of service issues with no threat of remote execution, when limited to account holders, are likely to just be committed to the main development branch with no special attention. Those who are running such services are encouraged to build regularly from git.

## Which versions are affected by CVE-2020-28466?

7 open source packages ship an affected version, including github.com/nats-io/nats-server, nats and github.com/nats-io/nats-server/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/nats-io/nats-server` | Go | All versions | None |
| `github.com/nats-io/nats-server` | Go | All versions | 2.2.0 |
| `github.com/nats-io/nats-server` | Go | All versions | 2.2.0 |
| `nats` | Bitnami | From 2.0.0 | 2.2.0 |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.2.0 |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.2.0 |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.2.0 |

Products: Linuxfoundation Nats-Server.

## How do I fix CVE-2020-28466?

Upgrade github.com/nats-io/nats-server to 2.2.0 or later.

## Is CVE-2020-28466 being exploited?

There is no known exploitation of CVE-2020-28466 in the wild and no public exploit code.

## Other vulnerabilities in github.com/nats-io/nats-server/server

- [CVE-2022-28357](https://insights.sbomify.com/CVE-2022-28357/): NATS nats-server allows directory traversal via unintended path to a management action (critical 9.8)
- [CVE-2026-58253](https://insights.sbomify.com/CVE-2026-58253/): NATS Server: Route API Auth Bypass (high 8.8)
- [CVE-2022-24450](https://insights.sbomify.com/CVE-2022-24450/): Incorrect Authorization in NATS nats-server (high 8.8)
- [CVE-2026-33216](https://insights.sbomify.com/CVE-2026-33216/): NATS has MQTT plaintext password disclosure (high 8.6)
- [CVE-2026-58207](https://insights.sbomify.com/CVE-2026-58207/): NATS Server: Remote crash via integer overflow in Connz pagination (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-28466 and fix it if it is affected.

What it is: CVE-2020-28466 is a high-severity denial of service vulnerability in github.com/nats-io/nats-server/server, published on 7 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-28466 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/nats-io/nats-server (Go): affected all versions; no fix listed
- github.com/nats-io/nats-server (Go): affected all versions; fixed in 2.2.0
- github.com/nats-io/nats-server (Go): affected all versions; fixed in 2.2.0
- nats (Bitnami): affected from 2.0.0; fixed in 2.2.0
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.2.0
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.2.0
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-28466/ (Markdown: https://insights.sbomify.com/CVE-2020-28466/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-28466
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-28466
- OSV: https://osv.dev/vulnerability/CVE-2020-28466

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-28466/
Summaries are generated and may contain mistakes; the official description above is the record.
